When installing Windows 10, I get a default computer name of the form DESKTOP-N1M453R.
Until recently, this has been fine, since I only had one computer with a name like this, so it was easy to identify at a glance.

Now, I have 3 Windows 10 machines on my network, all with names similar to DESKTOP-N1M453R. I'm bad at memorizing those strings, so I'd like to rename them.

I right click on "This PC", then click "Properties". I click "Change settings" in the "Computer name, domain, and workgroup settings" area. I click "Change" next to "To rename this computer..." I enter a new name and click "OK".

I get an error message "A general network error occurred."

enter image description here

Googling for this situation didn't lead to anything promising. Any ideas why I'm getting this error message and how I can workaround it?

  • You might want to check your Windows component store for errors. They could lead to strange behavior.
    – Daniel B
    Apr 1, 2017 at 14:51

3 Answers 3


Answer provided by Steven Murawski via twitter: https://twitter.com/StevenMurawski/status/848176681823203329

Use Rename-Computer at a PowerShell prompt (probably need Admin elevation to do it).

enter image description here

  • Did it work for you?
    – user477799
    Apr 1, 2017 at 15:54
  • Yes it worked, I'll mark it as answered in 2 days Apr 1, 2017 at 18:13
  • Glad to hear that your problem is resolved! If that solution worked for you, it might be wise to remove the "probably" from your answer, dependent upon whether it actually did or did not require an elevated PowerShell prompt when you utilized it.
    – Run5k
    Apr 1, 2017 at 18:46
  • This is the only solution that worked for me. Every GUI option gives me an error that isn't useful or tells me "The PC name is invalid'. Thanks @MatthewGroves Oct 23, 2018 at 13:58

Looks like contention for same name with cloned installations, so somehow disconnect networking and change all PC's to unique names following naming rules

  • 1
    What is your evidence? Your source?
    – user477799
    Apr 1, 2017 at 15:55

I was able to use GUI to rename my host after I deleted my teamed nics on Server 2022 standard. After reboot, I recreated the nic team and all is well.

Hope someone finds this useful


  • 1
    For people that don't know, please explain what nics is, in your answer. Feb 2 at 5:45
  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Feb 2 at 5:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.