2

In hotels and many other places they offer WiFi as a paid service. The network is open, but when you connect you will be redirected to a page where you pay for internet access, or enter a code.

On many networks now at various hotels across the USA I am able to connect successfully and load the redirect page on a Windows 7 computer, an iPad, and an Android. But on my Surface Pro 4 I can connect but it will not load the redirect page. It automatically opens a tab in my default browser and attempts to load a page at go.microsoft.com, but it just hangs there forever. It has loaded the redirect successfully a few times, but only after 10 to 20 minutes of waiting and a lot of cursing.

I've tried different browsers and even typing the URL to the redirect page, as it appears on a different device.

Is there some trick I can do to learn the redirect page and force it to load? Is there some kind of protocol I can do to get a diagnosis of the problem? I only have the one Windows 10 device, so maybe there is a setting I am unaware of that is blocking the redirect.

2
  • 1
    Try going to neverssl.com first
    – DavidPostill
    Apr 1 '17 at 20:33
  • @DavidPostill I've tried http sites, rather than https, many times, and it hasn't worked, but I'll try this specific one.
    – 287352
    Apr 1 '17 at 21:39
1

We have two possibilities here. Your browser/Windows is caching the DNS or it's configured to use a static DNS server.

First check your IPv4 config on your network adapter. See how to config IPv4. It must be configured to "automatically".

Force your windows to flush the DNS cache:

  1. Open cmd as Administrator.

  2. Type ipconfig /flushdns, press Enter.

  3. Disconnect and connect again.

  4. Open a browser and try to open google.com.

You must be redirected to the authentication/login.

4
  • Thanks for the answer. At the time, I believe I tried both of these in several ways. Currently, the issue no longer exists. I blame a bad Win 10 update.
    – 287352
    Oct 16 '17 at 19:11
  • I am currently having this problem and that isn't fixing it. No clue what to do next. Aug 8 '18 at 17:27
  • Hi @PeteMancini try to open a site you never opened before. like google in a different country .it .ca .com.br ....
    – Alexrgs
    Aug 8 '18 at 22:20
  • @alexrgs thanks. Figured it out. Popups were blocked. Aug 10 '18 at 10:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.