10

After a recent windows 10 (windows insider) update I'm getting gibberish text instead of English in some apps

Gibberish text inside IrfanView dialog

The windows fonts view in control panel is showing gibberish letters for some fonts too (fonts with the codepage number 1255 in their name)

text

I'm using Hebrew for non-Unicode languages (the problem doesn't exist when non-Unicode language is set to English). I tried reinstalling Hebrew language, copying default windows 10 fonts. My brother`s pc with same OS has this problem too.

7

3 Answers 3

2

This issue was a Windows issue and is already fixed with a Windows Update.

https://support.microsoft.com/en-us/help/4020102/windows-10-update-kb4020102

Addressed issue where some non-Unicode fonts (Courier, MS Sans Serif, etc.) do not render characters correctly on non-Latin, single-byte system locales (Greek, Hebrew, Arabic, etc.). Black bars or other artifacts appear instead.

6

Method 1 in this link fixed my problem after creators update:

https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/windows-10-english-system-text-show-as-gibberish/93cd572c-886e-419b-8889-531cff288223

Change Language settings through Control Panel.

  • Type Control Panel into the search bar on desktop and select the same from the list.
  • Click on Clock, Language, and Region.
  • Click Region, then go to Administrative tab.
  • Make sure that English (United States) is displayed under Current language for non-Unicode programs or as per your region. If not change it to the same. If it ask to reboot your PC, do the same.

Now check if it return back to normal language. If in case you need to make changes to the font and restore it to default, then follow with the below steps.

  • Type Control Panel into the search bar on desktop and select the same from the list. Click Appearance and Personalization, and then click Fonts.

  • In the left pane, click Font settings.

  • Click Restore default font settings. Then restart your PC and check if it take changes.

2
  • Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change.
    – DavidPostill
    Apr 13, 2017 at 19:38
  • 3
    Also that's hardly a solution, as I do actually NEED the Non-Unicode Languages to work with Hebrew in my case.
    – Elad Avron
    Apr 14, 2017 at 7:10
0

The currently accepted answer is obsolete for newer versions of Windows 10. @ramiwi, please consider accepting this one instead.

Here's another version-free way to fix this based on Microsoft's Hebrew answer.

Microsoft doesn't admit it, but obviously the answer is that even if you installed Hebrew for non-Unicode programs, it might have been installed wrong, so the solution is to choose another language, and only then bring back Hebrew, thus triggering a re-installation of it.

  1. Enter Control Panel=>Region=>Administrative
  2. Do you have Hebrew there?
    1. If not, click Change system locale... and change to Hebrew.
    2. If yes, click Change system locale... and change to anything else, most helpful is to English (United States).
  3. Click OK
  4. Agree to Restart

After the restart, only if you originally had Hebrew there, then:

  1. Go back to Control Panel=>Region=>Administrative
  2. Click Change system locale... and change to Hebrew.
  3. Click OK
  4. Agree to Restart

Region=>Administrative screen

Region=>Administrative screen=>Select language

Not the answer you're looking for? Browse other questions tagged or ask your own question.