14

Recent changes to Google Chrome altered how PDF files are handled. My extreme preference is that PDF files are only downloaded. I will then open the file in my system default PDF viewer if needed.

When I'm downloading several manuals that pertain to a specific piece of equipment, I do NOT need to view those manuals immediately. My goal is to simply download them to local storage as quickly as possible.

Chrome v56 no longer allows the built-in viewer to completely disabled. The only option is to go to Settings -> Content -> tick the box that says to open the PDF file in the system default PDF application.

This is NOT what I want. Quite simply, I do NOT want the PDF file to open automatically at all. Save the file; do NOT open the file.

I have tried right-clicking the download link for the PDF file and selecting "Save Link as ..." but that behavior has now changed as well. Specifically, most of the time, what gets downloaded is a URL rather than the PDF file.

FWIW - my download setting in Chrome points to the top-level directory in my Download folder and the check box "Ask where to save download file" is ticked.

Is there any way to persuade Chrome to revert back to previous behavior and just download the file to local storage?

  • I thought this would be easier but I was wrong. Turns out you can disable the internal viewer but you're trading it for opening in whatever app is registered to view PDFs. Also, there are a lot of answers involving chrome://plugins which doesn't seem to be available anymore. – Ouroborus Apr 7 '17 at 19:40
  • It is claimed that toggling "Open PDF files in the default PDF viewer application" off and then on again makes it work as before. I tried it and it worked for me, but only for this one session. If it doesn't work for you, try it again in incognito mode. – harrymc Apr 7 '17 at 20:09
9
+50

The issue may have to do with the way files are served by web servers.

Some servers may include Content-Disposition: attachment header in their response leading to Chrome downloading the file when you click on the download link while others may skip that header in their response, leaving the decision of whether to open or download the file up to Chrome.

More info on this here:
Force to open “Save As…” popup open at text link click for pdf in HTML
Do I need Content-Type: application/octet-stream for file download?

The following solution will download all PDF files including embedded files meant to be viewed within Chrome like the one's here and here. However, it won't work for sites using PDF.js to display embedded PDF files, like this online demo.


Adding or modifying Content-Disposition headers on the fly to Content-Disposition: attachment for MIME type application/pdf should help force Google Chrome to download all PDF files.

You can achieve this with the Modify Content-Type extension.

  1. Install the extension and click on the extension icon in the toolbar and select Options
  2. Click on Add Rule and add the following rule: Modify Content-Type extension settings
    Name:               Download PDFs
    URL Filter:         .*
    Original Type:      application/pdf
    Replacement Type:   application/pdf
    Disposition:        attachment
    
  3. Click Save Rule
  4. Refresh the page containing the PDF links so that the extension is loaded for that that page
  • Not working! As other answers here and other places, this leads them to be opened in external viewer (Acrobat or Edge), regardless of Content-Disposition. There is no way to just download pdf-s like it is possible with other file types. – Rauli Rajande Jun 29 '18 at 9:23
  • @RauliRajande Can you share the URL where this doesn't work? – Vinayak Jun 29 '18 at 9:37
  • eightalbertembankment.com , there "download event flyer". But the same thing happens with any gmail pdf attachment, when I click "download" arrow. – Rauli Rajande Jun 29 '18 at 9:42
  • There are two problems with this 1) privacy - as I am working in open plan office and sometimes dealing with private documents from my clients, so I don't want everyone to see them, especially when there are images, and 2) as there is no normal download button after downloading, I have to manually find downloaded pdf in default downloads folder to move them to archive folders. – Rauli Rajande Jun 29 '18 at 9:50
  • Checked Chrome bugtracker - this is recurring problem there, but always gets closed with "Can't reproduce". Funnily this happens to me in both my work and on my home PC. For example bugs.chromium.org/p/chromium/issues/… – Rauli Rajande Jun 29 '18 at 9:56
5

There is a setting for this now (Version 61):

Go to: chrome://settings/content

Scroll down to the PDF-documents section and select option to Download PDF files

Not sure exactly when this was changed. In version 58 there is a similar option to Open PDF files in the default viewer, but this has the same effect in linux (possibly different on other platforms).

0
  • settings
  • privacy and security
  • content settings
  • PDF documents
  • turn on the "Download PDF files instead of automatically opening them in Chrome"
-2

Just update the browser to the latest version, it got fixed.

protected by Community Jul 7 '18 at 4:37

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.