0

The current default settings "Enable session snapshot and periodic backup" every 7 seconds to the default AppData path are not creating any backups. There is a single backup file that was created over a week ago and nothing else.

I've updated to the most recent version and there are still no backups being created.

I've selected "Simple backup" under the "Backup on save" setting, but it does not backup on save. It's really freaking me out after just having lost a page of code during a crash where it saved an empty file over the previously saved file I had been working in. How do I get backup working to prevent this unacceptable loss of data?

  • 1
    There are backups for the session under the given path as long the file is not saved - if saved there no need for the session backup. Did you enter a folder for the backup copies? – LotPings Apr 2 '17 at 17:46
  • No, I hadn't, but I had not realized this did not apply to file backups or that it does not create a backup unless the saved file is edited first. It was the result of a lot of hours coding, losing data to a crash, and then not seeing backups being created. I figured it out though, thank you. – iyrin Apr 2 '17 at 17:56
1

Ok, well that was a testing failure mostly because Notepad++ does not actually create a backup upon saving the file as advertised by the "Backup on save" option. It creates a backup only if the file is both edited and saved.

Furthermore, it does not create the backup in the default AppData path when either "Simple backup" or "Verbose backup" are selected. These are separate from the "Session snapshot and periodic backup" setting. By default, it will create a new folder called "NppBackup" in the working directory of the file your are editing. Setting the directory path under the "Custom Backup Directory" section works.

Backups are now being written for every file that is edited and saved. I had interpreted the "Backup path" setting as meaning the default path for file backups, but it only applies to session backups. Just a little user experience issue, thankfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.