0

I've been having problems using the Filezilla FTP program to copy information from my computer to my D-Link 321 NAS drive.

As it turns out, it looks like when I created some of the files/folders using my mac and some of the files/folders using my PC, it created a problem with the permissions.

I found using this command in terminal seems to help unlock the folders so I can write to them, but all of the files nested in the folders also seem to have permissions that stop me from doing what I want to do.

chmod 777 /Volumes/Volume_1/<foldername>

Is there a command I can run that will make all of the folders and files on my NAS drive accessible (add, delete, rename) on my PC, my Mac and using an FTP client?

Also, do you recommend a setting other than 777 for all my folders and file? Why?

Thanks!

3

Yes, you can use

chmod -R u+rwX,g+rwX,o+rwX /Volumes/Volume_1/<foldername>

The -R flag applies the change to all folders and files recursively. Using the rwX symbolic mode will add read and write (rw) permissions for the user (u), group (g), and other users (o), and optionally permit execution (X) of files if they are already executable for somebody or if they are a directory. (This is equivalent to the 777 mode, except with a smarter executable bit.)

You may have to run this command as root by prefixing it with sudo if you get any 'permission denied' errors when running it.

  • Thanks! Seemed to work great. There are a few folders that got error messages. I'll try out the sudo prefix next! – bosstone75 Apr 4 '17 at 3:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.