1

I have the following problem on my MBP Pro mid 2015 16Gb RAM running Windows 10 with the latest BootCamp drivers, in Visual Studio 2015 and 2017 Community Edition.

Almost every time I alter my code Visual Studio has a significant video lag. Lines of code are messed up not showing actual code. I've tried reinstalling Windows, cleaned up Visual Studio, no effect.

Demonstration: screencast of the lag on YouTube.

0

There can be many many reasons for Visual Studio being slow.

I have tried to compile an exhaustive list of possible causes, where not all (or none) will apply to your case. You will just have to try and see.

  1. Go to Tools -> Options → Text Editor → C# → Advanced and uncheck Enable full solution analysis

  2. Go to Tools → Options → XAML Designer → General and uncheck Enable XAML Designer (requires restart of Visual Studio)

  3. Go to Tools → Options → Text Editor → All Languages and uncheck Enable CodeLens

  4. Go to Tools → Options → Debugging → General and disable Enable Diagnostic Tools while debugging

  5. Go to menu ToolsOptionsSource Control and set Current source control … to None

  6. Go to menu ToolsOptionsEnvironmentSynchronized Settings and uncheck.

  7. Clean the contents in the following cache folders (do not delete these folders, instead delete their contents only) and restart Visual Studio:

    • Clean the content in WebSiteCache folder (can be found in
      C:\Users\%USERNAME%\AppData\Local\Microsoft\WebSiteCache)

    • Clean the content in Temporary ASP.NET Files folder (can be found in
      C:\Users\%USERNAME%\AppData\Local\Temp\Temporary ASP.NET Files)

  8. Change the scope of the Error List window to Current Document.

  9. Remove the .vs folder from the solution folder.

  10. Disabling some extension, for example ReSharper Code Inspection.

  11. Disable additional displays (second or third monitor)

0

In my case, and I had bad lag doing the simplest of things, it helped to update my pc drivers. The system drivers are the foundation for everything.

I was fortunate that Dell has awesome website support to do this. I let it update all the drivers it wanted to (Dell driver update is pretty much automatic).

Much of the lag seems to have gone away.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.