I've noticed that my Windows 10 is no longer updating itself. When I run the Settings app and issue an update command, this message appears.

There were some problems installing updates, but we'll try again later. If you keep seeing this and want to search the web or contact support for information, this may help: (0x80070006)

Of course, standalone updates install well. I have also been able to run a manual update from PowerShell and get Windows 10 to build 14393.970. Plus, Windows Defender keeps updating itself, so updating in general is possible.

I have tried running Microsoft Windows Update Troubleshooter. (The latest version from Microsoft website.) Nothing happened. I have also tried an equivalent from tenforums.com. Not only did it not fix my problem, it broke Windows Defender too. (System Restore came to rescue.)

  • What hardware are you using Windows 10 on? Did you try to delete the Windows Update cache and reinitialize Windows Update? – Lenniey Apr 5 '17 at 11:26
  • Over 100 people found this helpful, but I wouldn't think a Windows Update would try downloading to any other drive besides C:. – Tim G. Apr 5 '17 at 11:30
  • If it's any help, the textual equivalent of that message number is "The handle is invalid". – Jeff Zeitlin Apr 5 '17 at 11:31
  • 0x80070006 = invalid handle. I have no real idea how to trace this. update to Windows 10 1703 Creators Update and look if WU works here or not – magicandre1981 Apr 6 '17 at 15:44
up vote 7 down vote accepted

I have had this issue on my work PC and found that errors reporting an invalid handle can arise from Windows Update running in its own process.

You can try checking if Windows Update is running in its own process, and if it is, set it to share and reboot.

To check if it is in its own process, you can run sc query wuauserv in an elevated command prompt, and check what TYPE is reported. For example, one that is is set to run as its own process will look like this:

Microsoft Windows [Version 10.0.14393]
(c) 2016 Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>sc query wuauserv

SERVICE_NAME: wuauserv
        TYPE               : 10  WIN32_OWN_PROCESS
        STATE              : 4  RUNNING
                                (STOPPABLE, NOT_PAUSABLE, ACCEPTS_SHUTDOWN)
        WIN32_EXIT_CODE    : 0  (0x0)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0

To set it to shared (as it should be), run sc config wuauserv type= share, then reboot your PC (reboot is necessary because of some issue with SIDs not being correct without bringing down the shared process).

Once done, Windows Update should be working (provided there is nothing else wrong with it) and running sc query wuauserv should return a TYPE of 20 WIN32_SHARE_PROCESS.

  • Well, that's another bug to add to the ENDLESS list of Windows 10 bugs. – user477799 Apr 16 '17 at 4:55
  • I found a well-regarded Windows "clean up" powershell script set to make the Windows Update service run in it's own process. I've had to revert this on several PCs due to the error message discribed in this question. – Ian Gregory May 27 '17 at 14:39
  • Note that the sequence of steps provided did not resolve the issue for us. What was needed was after validating the service with the command SC QUERY WUAUSERV the next step needed to be SC STOP WUAUSERV then SC CONFIG WUAUSERV Once that was successful the command SC START WUAUSERV was used. At this final point the SC QUERY WUAUSERV command correctly shows the results TYPE : 20 WIN32_SHARE_PROCESS Paul B – Paul Jul 7 '17 at 13:37

As Logan Dam mentioned this command in elevated (admin) command prompt:

sc config wuauserv type= share

Appears to at least get you past the error and allows windows updates to run. You may however encounter a similar error over and over again but in my experience on the third attempt (after noticing it was installing different updates each time) this happened to be the fix.

It's worth noting I got different errors each time and eventually I was prompted to uninstall a piece of software that was holding it up.

So if this command doesn't work the first time, give it a couple attempts and you may see results. Be sure to reboot after each time you run this command.

  • Please don't add "thank you" as an answer. Once you have sufficient reputation, you will be able to vote up questions and answers that you found helpful. - From Review – Ben N Jun 1 '17 at 23:59
  • Thank you was never used, the point of the post was to mention that you may have to run this command multiple times it's not a 1-run fix and most people would probably abandon this 'fix' if it doesn't work the first time. I also wanted to note it wasn't me that found the command hence mentioning the other user. – M Seck Jun 2 '17 at 0:51
  • "well done Logan Dam", is what Ben is talking about when he says not to add "thank you", the original revision of this answer was basically a comment to an existing answer – Ramhound Jun 2 '17 at 2:39

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.