0

I installed Copssh (OpenSSH for Windows) and it worked. However I'm setting up a private git server and want to make the url for the git repositories shorter. So I reinstalled it but it's not working anymore.

$ ssh -vvv [email protected]
OpenSSH_7.3p1, OpenSSL 1.0.2k  26 Jan 2017
debug1: Reading configuration data /etc/ssh/ssh_config
debug2: resolving "192.168.1.128" port 22
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to 192.168.1.128 [192.168.1.128] port 22.
debug1: Connection established.
debug1: key_load_public: No such file or directory
debug1: identity file /c/Users/hp/.ssh/id_rsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /c/Users/hp/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /c/Users/hp/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /c/Users/hp/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /c/Users/hp/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /c/Users/hp/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /c/Users/hp/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /c/Users/hp/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_7.3
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.8
debug1: match: OpenSSH_5.8 pat OpenSSH_5* compat 0x0c000000
debug2: fd 3 setting O_NONBLOCK
debug1: Authenticating to 192.168.1.128:22 as 'hp'
debug3: hostkeys_foreach: reading file "/c/Users/hp/.ssh/known_hosts"
debug3: send packet: type 20
debug1: SSH2_MSG_KEXINIT sent
Connection reset by 192.168.1.128 port 22

I set the correct permission on the .ssh directory using chmod and in the authorized_keys file I added my public key. What else should I check to resolve this problem?

4
  • Share the entire log, not just the bit you think is important. That means both the server and client logs. Also what do you mean by 'make the url shorter' ? SSH doesn't use urls generally. Apr 5, 2017 at 11:56
  • @djsmiley2k I would add the log later.I was trying to use ssh to set up git private server which would generator a url for git repos. Apr 5, 2017 at 12:28
  • But why would you need to reinstall the ssh server in that case? That doesn't make a whole lot of sense? As others said, you will need to provide more details/logs. Right now the service might not be running, misconfigured, your firewall might be interfering etc.
    – Seth
    Apr 5, 2017 at 13:24
  • The firewall has turned off already.As I said it was working.More story is here. link Apr 6, 2017 at 0:58

0

You must log in to answer this question.

Browse other questions tagged .