2

I'm trying to run Spock tests with my project in IntelliJ 2017.1 community ed. While editing my spec file I get the error msg "Cannot resolve spock" on the import line with a "Configure Groovy SDK" link. When I click on that link I get the "Setup Library" dialog. It has a "Use library" folder search. So I locate my groovy-2.4.10 SDK folder and press Ok. Then I get this error msg:

Looks like Groovy distribution in specified path is broken. Cannot determine version.

I've checked and double-checked the groovy SDK folder. It's a complete groovy SDK folder as un-zipped from the prestine download I did from http://groovy-lang.org/download.html.

So I'm at a loss as to where to go next. Anyone run into this with IntelliJ 2017.1 community ed?

0

CrazyCoder's comment to my question is the answer. Upgrade to 2017.1.1 version of IDEA solved the issue.

It's a known issue:

  • IDEA-170022 Cannot create Groovy project, because cannot create Groovy library (2.4.10 version)

As a workaround you can use Groovy 2.4.9 or rename groovy-2.4.10.jar to groovy-2.4.9.jar.

The problem is fixed for IntelliJ IDEA 2017.1.1 and 2016.3.6 versions.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.