0

Since March, I've been trying to figure out what keeps causing my home drive to get flagged as read-only after a cold boot.

I tried a new drive since that could be the sign of a failing drive. Things were fine until I rebooted to apply updates. When that didn't fix it, I replaced the cables running to it, but the same thing occurs. Even changing where on my motherboard it plugs in did this.

I really don't have the budget to replace the motherboard and its parts for repeat behavior. Weirdly, it is specifically the drive I use for /home, none of the other three are affected.

Elementary OS 0.4

ASUS M5A97 R2.0

WD Blue HDD

/Home mountpoint formatted as ext4

If you want a snippet of the ata4 errors I'm getting or anything else, I'll happily provide them.

/etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sdb1 during installation
UUID=1870426d-19c1-4876-82a3-f61198015595 /          ext4    errors=remount-ro  0       1
# /backup was on /dev/sda1 during installation
UUID=ec59d05e-822b-48a4-bc62-dc3f7a1413ee /backup    ext4    defaults           0       2
# /home was on /dev/sdc1 during installation
UUID=7d87f6fd-504d-4401-b1c6-dbdc33e2d6c6 /home      ext4    defaults           0       2
# /steam was on /dev/sdb3 during installation
UUID=35f1f5ae-0a57-41a9-b577-45f9a3224472 /steam     ext4    defaults           0       2
  • can you add the result to your question of cat /etc/fstab ? – Michael D. Apr 7 '17 at 17:29
  • I have added the fstab. Took me a while to get signed in on another computer and the formatting right. – Zachs Kappler Apr 7 '17 at 19:03
  • When it happens, can you remount as read-write by sudo mount -o remount,rw /home? – Kamil Maciorowski Apr 7 '17 at 19:53
  • Nope. I tried that the first time it happened and this last time. The other commands I tried refused to work because something deeper made the entire drive write-protected. The only thing that could change it was fsck and a reboot, but the change doesn't last long after getting logged in. – Zachs Kappler Apr 7 '17 at 19:56
  • I would still suspect hardware. Read this. You mentioned some errors; are they like these? Your fstab tells me you had at least three separate devices (sda, sdb, sdc) during installation. Maybe your power supply unit is somewhat faulty and they are too much burden? Can you monitor voltages? (try sensors command, lm-sensors package in Ubuntu, I don't know Elementary OS). Some disks may be more power-hungry than others: HDD needs more power than SSD, 7200 RPM usually needs more power than 5400, etc. – Kamil Maciorowski Apr 7 '17 at 20:38
0

The power supply cables were found to be faulty. The worst one had broken inside the insulation, and another at the connector after I pryed it open. Thankfully it's one of those modular power supply units, so I can just replace them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.