167

It used to be possible to disable internet search results in start menu searches before the Windows 10 Creators Update, but I've just clean installed a new Windows 10 Pro image and that setting is gone. Is there some way to disable it through editing the registry/etc?

193
+100

The article The Windows 10 spring update no longer lets you disable web search in Start - workaround reports that the following registry update is required in Windows 10 version 1803 :

Windows Registry Editor Version 5.00
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Search]
"BingSearchEnabled"=dword:00000000
"AllowSearchToUseLocation"=dword:00000000
"CortanaConsent"=dword:00000000

It remarks :

those entries are completely missing from the "Search" registry key, so you can safely delete them should you want to revert.

I would still recommend to at least create a system restore point before doing any registry modifications.

A reboot might be required.

User @mtd has contributed below these commands for applying the updates to the registry:

reg add HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Search /f /v BingSearchEnabled /t REG_DWORD /d 0
reg add HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Search /f /v AllowSearchToUseLocation /t REG_DWORD /d 0
reg add HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Search /f /v CortanaConsent /t REG_DWORD /d 0

There are reports that Windows 10 version 2004 has broken the above fix.

The article Disable Web Search in Taskbar in Windows 10 Version 2004 has a summary of the current state of the problem.

The current solution seems to be to download and run this PowerShell script as Administrator:

Set-ExecutionPolicy Unrestricted -Scope Process
.\disable-web-search.ps1

As only a workaround, this PowerShell script blocks the online search using Windows Firewall rules, so forcing the search to operate in offline mode.

| improve this answer | |
  • 7
    Confirmed that these registry edits successfully disable the web search. The start menu wasn't turning up many search results on my local disk when I initially made those registry changes (even after restarting explorer.exe), but after a few minutes that problem resolved itself. – Drew May 27 '18 at 22:36
  • 18
    You can just kill SearchUI.exe to have this kick in. When you then open the search panel -- Win+S -- it should say "apps, files and settings". If it still states "web results", make sure you added all keys. In my case, CortanaConsent was missing. – Smiley Barry Oct 3 '18 at 1:00
  • 3
    For some reason I couldn't see BingSearchEnabled or AllowSearchToUseLocation in the register editor GUI but I was able to disable web searches by running this in cmd reg add HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Search /f /v BingSearchEnabled /t REG_DWORD /d 0 – Charles Clayton Feb 5 '19 at 20:01
  • 3
    works on 1903 ✔ – JinSnow Jul 31 '19 at 4:12
  • 3
    Works on 1909 ✔, no reboot required – Martin J.H. Jan 12 at 20:38
99

This has been required since Windows 10 Version 1607. Configuring the group policies below will only work if you are running Windows 10 Version 1607, Windows 10 Version 1703, or Windows 10 Version 1709. You must be running Windows 10 Professional or any applicable version of Windows 10 for these group policy changes to take effect.

  1. Start the Local Group Policy Editor
  2. The policy you’re looking for is located at

Computer Configuration → Administrative Templates → Windows Components → Search

  1. Set Allow Cortana to Disable
  2. Set Do not allow web search to Enabled
  3. Set Don't search the web or display web results in Search to Enabled
  4. Restart

enter image description here

Image Source:

Additional Sources:

| improve this answer | |
  • @EdwardBrey - The answer has been updated. – Ramhound Oct 14 at 2:51
6

While @Ramhound solution and @harrymc solution are certainly the most direct, there is also a useful free third part program, that can edit many of these hidden settings, including the turning off of Internet Search in Cortana.

O&O ShutUp10 means you have full control over which comfort functions under Windows 10 you wish to use, and you decide when the passing on of your data goes too far. Using a very simple interface, you decide how Windows 10 should respect your privacy by deciding which unwanted functions should be deactivated.

O&O ShutUp10 is entirely free and does not have to be installed – it can be simply run directly and immediately on your PC. And it will not install or download retrospectively unwanted or unnecessary software, like so many other programs do these days!

( Website and Direct Download )

Example of cortana settings in the program:

Cortana Settings

| improve this answer | |
  • 1
    oo-software.com is reliable? How to confirm that there are no trojan? – Peter Krauss Jul 16 '19 at 16:44
  • @PeterKrauss You will have to read up on them your self. They have been around for a long term, a german company, and are certified microsoft partner; see there history here oo-software.com/en/company – Under A Tree Feb 8 at 4:29
  • @PeterKrauss basically they have been around for a long time, and there products can be found across the internet. cnet page , mwc , amazon , shop , shop2. – Under A Tree Feb 8 at 23:51
  • Ok ok, it is like any other black-box: non-reliable. Only auditable (simple and non-chaotic) open source is reliable. But, no other options for ugly-Windows, ok: german company and long term sorftware (confirmed), and your approval, it is a good credential. ...I used and was good (!), more one up vote! – Peter Krauss Feb 9 at 22:30
-3

And for these who is looking for disabling web search via registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Windows Search

create new 32-bit DWORD value ConnectedSearchUseWeb and set it to 0

Reboot.

Reference

| improve this answer | |
  • This doesn't work on Windows 10 home – Natan Yellin Feb 27 '18 at 13:43
  • 1
    @NatanYellin what if you add DisableWebSearch DWORD and set it to 1 Maybe reboot is required after all? – vanowm Feb 27 '18 at 22:39
  • Nope, that doesn't fix it either. The entire key "HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Windows Search" didn't exist originally. I created it, added both DWORDs you mentioned, rebooted... And websearch is still enabled. – Natan Yellin Mar 1 '18 at 13:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.