0
@echo off
for %%a in (*.mp3) DO ffmpeg -i "%%a" -f image2 -loop 1 -r 30 -i image.jpg -shortest -c:a copy -c:v libx264 -crf 23 -preset veryfast -vf scale=1280:720 "%%a.mp4"
pause

I have this batch code here, however it doesn't output correctly. The mp3 is successfully converted to a mp4, though the image is not merging with the audio.

I have the audio and the jpg called image.jpg in the folder together.

| |
  • You probably just need to add -pix_fmt yuv420p output option. – llogan Apr 8 '17 at 3:21
-1

missing output -pix_fmt yuv420p From Lordneckbeard

| |

Not the answer you're looking for? Browse other questions tagged or ask your own question.