50

I have an Acer 1810T and am going to buy a Dell u2711 with a resolution of 2560 x 1440.

Can I connect the panel over HDMI with the Acer and use the 2560 x 1440 res?

14 Answers 14

33

According to this article on Wikipedia, it should be fine if your Acer supports HDMI 1.3.

HDMI version 1.0-1.2a 1.3 1.4
Maximum signal bandwidth (MHz) 165 340 340 [50]
Maximum TMDS bandwidth (Gbit/s) 4.95 10.2 10.2
Maximum video bandwidth (Gbit/s) 3.96 8.16 8.16
Maximum audio bandwidth (Mbit/s) 36.86 36.86 36.86
Maximum color depth (bit/px) 24 48[A] 48
Maximum resolution over single link at 24-bit/px[B] 1920×1200p60 2560×1600p75 4096×2160p24
Maximum resolution over single link at 30-bit/px[C] N/A 2560×1600p60 4096×2160p24
Maximum resolution over single link at 36-bit/px[D] N/A 1920×1200p75 4096×2160p24
Maximum resolution over single link at 48-bit/px[E] N/A 1920×1200p60 1920×1200p60

HDMI 1.3 supports resolution 2560x1600 at 75Hz at 24 bits/pixel, and 60Hz at 30 bits/pixel.

5
  • Thanks, Intel says the GMA 4500 Series supports HDMI 1.3a - so hopefully it works ;) software.intel.com/en-us/articles/…
    – ben
    Mar 14, 2010 at 12:02
  • 29
    Sadly, it didn't work.
    – ben
    May 25, 2010 at 19:30
  • 1
    Just because on part of the chain (HDMI 1.3) supports it does not mean it will work. And there are many post about limited resolutions on Intel chips. Interesting enough some Linux people do get it to work, making this a likely driver problem.
    – Hennes
    Aug 27, 2016 at 14:16
  • 1
    NOTICE! I am running a Dell 2711 over HDMI at 2560x1440 @ 60Hz, so it certainly works. Look at my answer.
    – stolsvik
    Aug 28, 2016 at 6:58
  • Late Gen4 may even support HDMI 1.3 natively, but if you check the 4 series chipset datasheet you can see how that's still limited to a 165MHz dot clock - i.e. the same of HDMI 1.0. In fact, if you check the mobile one (where somehow they had a snafu while typing that information) GMA 4500MHD sounds to even be on a <1.2 feature set.
    – mirh
    Jan 27, 2021 at 18:18
40

Dell documentation states that the U2711 HDMI port is (internally) limited to 1920x1080.

5
  • 1
    @g scott: Interesting. Do you have any idea why they did this?
    – boehj
    May 15, 2011 at 10:15
  • Please see my answer for a workaround.
    – Tom
    May 21, 2014 at 1:04
  • 6
    Ignore the documentation! Dell claim their U2713HM is also limited to 1920x1080 over HDMI. But they're wrong! I've been using it at 2560 x 1440 over HDMI without difficulty. On Ubuntu and also on Windows7. I have to 'force' it (Ubuntu: using the xrandr tool as per the answer of xramonz. Windows: check how to insert a 'custom resolution' for your graphics card.) This might void your warranty, and cause everything to go up in flames. Apparently. Use at your own risk. Sep 19, 2014 at 14:27
  • 2
    THIS ANSWER IS PLAIN WRONG, and the link even goes to 404 Not Found. I tried editing it, but the edit wasn't accepted - better with a wrong answer and leading people astray, than loosing potential points, I guess: I am currently running that exact monitor, Dell 2711, at its native resolution 2560x1440 @ 60 Hz over HDMI. Look at my answer..
    – stolsvik
    Aug 28, 2016 at 6:56
  • Don't be so harsh on Dell and/or the answer: The monitor, in it's EDID, clearly limits the pixel clock/resolutions, which is an internal limiting - the fact that you can effectively "overclock" the HDMI input with out-of-spec frequencies does not change the fact that the monitor internally limits the legal video modes. Mar 13, 2020 at 10:22
16

I made my Dell U2711 work at 2560x1440 over HDMI, by pointing xorg.conf to a custom EDID file someone created.

...

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL U2711"
    HorizSync       30.0 – 81.0
    VertRefresh     56.0 – 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400M GS"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "CustomEDID" "DFP-1: /home/dlawson/u2711/dell_u2721_custom.edid"
    Option         "metamodes" "DFP-1: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
5
  • 4
    It would be nice to include the essential parts of the answer here, and provide the link only for future reference.
    – slhck
    Sep 4, 2011 at 16:21
  • 2
    That's right. Before anyone else rushes to buy this monitor for his or her laptop, I should also point out that I've only succeeded to run full resolution at a 35Hz refresh rate. Which doesn't look terrible - the mouse cursor's motion is jumpy, and I haven't tried looking at any video. I would look for another monitor if I hadn't bought it already.
    – alex k
    Sep 5, 2011 at 14:21
  • 1
    the link to EDID file is broken, any idea where I can find this file?
    – Aras
    Oct 26, 2012 at 2:18
  • 1
    I don't have the EDID file anymore.
    – alex k
    Feb 4, 2014 at 10:09
  • I didn't need the EDID file. See randr answer by stolvik.
    – John Mee
    Jun 18, 2019 at 6:58
13

It's an older thread but I thought I would add my two cents in. Running Windows 8.1 RTM on a Retina Macbook Pro which has a NVIDIA GeForce GT 650M connected to a Dell U2711 via HDMI I managed to get it working by creating a custom resolution using the following settings (note the CVT Reduced Blank selection):

2560x1440 60Hz CVT RB Custom Resolution

The monitor info now shows resolution as "2560x1440@60Hz". The following post helped: 2560x1440 or 2560x1600 via HDMI

5
  • Works great for my U2711 using HDMI! Jan 30, 2016 at 11:41
  • Additional info to the link: interestingly 50 or 55 Hz, can't remember, did not work: screen was wrong and flickering. 59 Hz though is working (did not try 60 Hz). After adding a custom resolution Windows restart was needed for it to be available. (Windows 10, Intel HD 520, standard HDMI cable)
    – sevenforce
    Aug 28, 2016 at 16:51
  • Worked perfectly for my GeForce GTX 1060 connected to U2711 over HDMI. Sep 7, 2017 at 16:30
  • My old desktop with i5 2320 and GeForce GT 440 can now use my QHD (HP Omen 32') with this crispy resolution. Thank you so much!
    – ThinkCode
    Oct 19, 2017 at 13:49
  • "CVTR Reduced Black" did the trick no more fuzzy text. Thank you so much for this tip. Mar 25, 2021 at 21:16
6

I found many questions from people wanting to connect their 2560x1440 monitor on a laptop that does not support display-port or DVI.

I have a ASUS K93S and a IIYama XB2776QS and only after purchase I found in the manual that in order to use 2560 x 1440 I could only use the DVI dual link port or the displayport. Both of these connectors are not available on my laptop.

I searched the internet.

But as I didn't find a clear answer anywhere I thought I might let you know how I solved it. I am not sure if it will help you, but all I can tell you is that it worked for me.

After much digging I found that in theory a HDMI 1.3 device should be able to do this as long as a HiSpeed HDMI cable is used. Than I found that for some reason manufacturers cannot Always state the version of the HDMI they include (For my Asus I could not find it, although HDMI 1.3 is already quite old I did assume my laptop has at least HDMI 1.3).

I found that HDMI 1.3 and up need a High-Speed cable.

So I used a HiSpeed 2160P HDMI cable (actually it also supports ethernet). But just connecting to my IIYama XB2766QS gave me a max resolution of 1920 x 1080.

Than after much digging I found that it is possible to create your own resolution (at least with my NVidia VGA driver). I must warn you that you must be sure that your monitor is capable of displaying that resolution, because apparently it is possible to damage your monitor of you set the resolution etc. to high. .

So I connected my monitor, and in the NVidia driver where I could select the resolution I added the resolution 2560 x 1440 (60Hz, progressive). I pressed test (and it worked). Then I saved the resolution and choose the resolution.

Hip hip hooray, it worked.

3
  • 1
    Welcome to SuperUser. No need for a signature here, you're SU provides one for you.
    – dav
    May 17, 2013 at 14:08
  • I did the same but the text is blurry and hard to read compared to 1920x1080. It's weird because if I use another computer with DisplayPort instead of HDMI, the graphics are displayed just fine.
    – tiktak
    Oct 2, 2014 at 8:29
  • 1
    If text is fuzzy then it's a display SCALING problem. While the resolution is set properly the display adapter thinks it has to double the pixels itself. You can fix this by going to Intel Graphics Properties then on the monitor click Maintain Display Scaling. It should be the first option. Don't enable Maintain Aspect. Then that should fix the problem. NVIDIA and AMD have similar options. Remember there is what the OS thinks is the desktop resolution and what the monitor resolution is. If it thinks they don't match it'll try to scale one way or the other. Jul 31, 2016 at 17:11
5

2560x1440 @60Hz working fine: Here's some xrandr numbers (30, 41, 55, 58 and 60Hz, all good), they work on my DELL 2711b monitor and "[AMD/ATI] Pitcairn XT [Radeon HD 7870 GHz Edition]" graphics card, and a fat HDMI cable. Edit 2022-04-19: Also working on laptop: ThinkPad X1 Extreme Gen2 with "GeForce GTX 1650 Mobile / Max-Q".

# Create new modelines:
xrandr --newmode "2560x1440_30" 146.25 2560 2680 2944 3328 1440 1443 1448 1468 -hsync +vsync   # 29.94
xrandr --newmode "2560x1440_41" 162.00 2560 2608 2640 2720 1440 1443 1448 1468 +hsync +vsync   # 40.57
xrandr --newmode "2560x1440_55" 220.812 2560 2608 2640 2720 1440 1443 1448 1478 -hsync -vsync  # 54.93
xrandr --newmode "2560x1440_58" 231 2560 2608 2640 2720 1440 1443 1448 1468 -hsync -vsync      # 57.85

# Edit 2022-04-19: Exact 60Hz mode, Calculation: 0.00006*(2700*1460) = 236.52 (exact)
xrandr --newmode "2560x1440_60" 236.52 2560 2590 2630 2700 1440 1443 1448 1460 -hsync -vsync  # 60Hz exact.

# Add the modes you want to the available set for the output:
xrandr --addmode HDMI-0 2560x1440_60

# Enable the mode for the output:    
xrandr --output HDMI-0 --mode 2560x1440_60

xrandr  # To see the results.

They're collected from @xramonz and Phil highland74's answers, and http://www.notebookcheck.net/2560x1440-or-2560x1600-via-HDMI.92840.0.html - and then playing hard with the dot clock on the first argument.

To make it possible to create those modelines, you need to disable checks by Nvidia in /etc/X11/xorg.conf:

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1650"
    Option         "ModeValidation" "AllowNon60hzmodesDFPModes, NoEDIDDFPMaxSizeCheck, NoVertRefreshCheck, NoHorizSyncCheck, NoDFPNativeResolutionCheck, NoMaxSizeCheck, NoMaxPClkCheck,  AllowNonEdidModes, NoEdidMaxPClkCheck"
EndSection

Also, to get the DELL U2711 monitor to accept those frequencies, it seems like this does the trick:

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL U2711"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 76.0
EndSection

It hasn't exploded yet (5 minutes and counting.. Edit 2022-04-19: ~2 years and counting..)

Update 2019-06-22: I now also run 2x these from a MacBook Pro, over HDMI using two different USB-C to HDMI dongles (the DELL 2711's DP ports are already used for my stationary Linux box). Using a Mac shareware program called SwitchResX, I could hack the dot clock there too, and again got it to work 2560x1440 @60Hz: https://apple.stackexchange.com/questions/63259/macbook-pro-w-retina-display-connected-to-dell-u3011-monitor-via-hdmi-periodi#comment479831_63262

1
  • 1
    Works for me. Woot! Lenovo E470 (Nvidia 940MX) + Dell U2713HM via HDMI
    – John Mee
    Jun 18, 2019 at 6:57
4

Dell U2713HM 2560x1440@41Hz via hdmi as second monitor on my laptop:

xorg.conf

...
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"

    Option         "HorizSync" "DFP-0: 30.0-75.0; DFP-1: 31.5-88.8"
    Option         "VertRefresh" "DFP-0: 56.0-75.0; DFP-1: 29.0-76.0"

    # laptop screen
    Modeline       "1366x768_60" 70.615 1366 1414 1446 1526 768 770 775 790 +hsync +vsync
    # dell u2713hm
    Modeline       "2560x1440_41" 162.00 2560 2608 2640 2720 1440 1443 1448 1468 +hsync +vsync
    Modeline       "1920x1080_60" 148.50 1920 2008 2052 2200 1080 1082 1087 1125 +hsync +vsync
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 240M"

    Option         "ModeValidation" "NoDFPNativeResolutionCheck"
    Option         "ExactModeTimingsDVI" "True"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option "TwinView " "on"
    Option "TwinViewOrientation" "Clone"

    Option         "TripleBuffer" "1"
    Option         "OnDemandVBlankInterrupts" "1"
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"

    Option "metamodes" "1366x768_60, 2560x1440_41"

    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

By the way, in documentation this monitor also has limitation 1920x1080@60Hz via hdmi, but with custom modeline (or custom resolution through nvidia panel in windows) works fine.

1
  • xrandr is a very convenient program for experimenting with new modes. It should be on your machine already, I think. See the man page under 'Examples'. Beware though, it doesn't automatically revert if it failed (I think), so beware of that when executing the command - you should incorporate a 10 second delay and then another xrandr command to use a known-working resolution Sep 10, 2014 at 13:24
4

After a good deal of experimentation I can now happily report that it is possible to run a Dell U2711 as an external monitor at 60Hz / 2560x1440 from the Intel HD 4400 integrated graphics card on a Windows 8.1 laptop.

They didn't make it easy though, and I'm not sure what the reasons for this are... so experiment at your own risk!

First of all, you will need a high quality HDMI to DVI-D (24 pin) cable, capable of carrying the required bandwidth. I found this did not work with the when connecting to the HDMI port of the monitor however connecting to the DVI input does work.

The main problem boils down to the custom resolution app simply not accepting higher refresh rates at this resolution. "The custom resolution exceeds the maximum bandwidth capacity" (If you are happy with 40Hz you do not need this hack and can simply add a custom resolution at 40Hz - the maximum it will take)

Since 60Hz used to be possible with a previous driver release (sadly not compatible with Windows 8.1) I reasoned that if I could add the 60Hz custom resolution then it would indeed work.

It turns out that custommodeapp stores newly created custom resolutions at the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0000\C_MODES_DFP_79

One of the bytes in here is for the refresh rate.

First remove all custom resolutions you may have created. Then add one at 2560x1440@30Hz..

Now go and edit that reg key (run regedit)... Find byte 0x4D.. you should see this set to 0x1E : 30 Hz

Just change byte 0x4D to 0x3C (60 Hz)

Now restart your computer!

2
  • 4
    Unfortunately this hack only changes the numbers in the GUI. The actual refresh rate is still 30Hz.
    – n. m.
    Jun 13, 2014 at 20:27
  • 1
    @n.m. :-D well I'm not sure who to believe now. I would say 30Hz are pretty visible (and quite unusable for any kind of work). Also I'm not sure I understand what is the issue here - once you use HDMI to DVI adapter capable of 1440p@60, you no longer have issue with the crappy HDMI port on the DELL monitor because the signal is now DVI that can handle that.
    – icl7126
    Jan 26, 2018 at 20:25
2

I work with Linux Mint 18 with a Dell U2711 (2560x1440).

To get the max resolution of 2560x1440, type this in the terminal:

xrandr --newmode "2560x1440_60.00" 146.25 2560 2680 2944 3328 1440 1443 1448 1468 -hsync +vsync
xrandr --addmode Virtual1 2560x1440_60.00
1
  • Thanks! Although, 'xrandr' by itself shows that it runs on 29.94 Hz. Based on @xramonz answer, this line gets it up to 40.57Hz: "2560x1440_41" 162.00 2560 2608 2640 2720 1440 1443 1448 1468 +hsync +vsync
    – stolsvik
    Aug 27, 2016 at 10:22
2

Windows 10, cheap HDMI cable, Dell 27", HP Laptop w/ Intel HD 4000 graphics:


Here are the steps I did with success after hours of trials & error:

Right click desktop and select "Graphics options" and then "Custom resolution":

enter image description here

Right click desktop and select "Display Settings" (windows 10)

enter image description here

enter image description here

enter image description here

1
  • I have later discovered that the HP docking station (connected to my laptop using USB-C cable) cannot handle 2 high-res monitors + laptop screen, so after connecting one directly to the HDMI of the laptop rather than that of the docking station, all monitors worked great at native-resolutions without any special configuration.
    – vsync
    Sep 10, 2021 at 8:10
1

I too do not have a display port on my asus zenbook, so I could not get my u2713 monitor to work at full resolution.

I attempted the HDMI custom resolution but setting it to 35 Hz was driving me nuts. So I bought a simple HDMI to DVI cable and then set the custom resolution to 2560x1440 progressive 59hz and changed the timing to CVT reduced blank.

The CVT reduced blank and 59hz is vital, otherwise the image is blurry and will periodically cut out.

2
  • 2
    Welcome to Super User! As we are not a forum, there's no need to worry about "Reviving an old thread". The very nature of questions here is about constantly editing and adding new answers and content. Nov 10, 2013 at 2:20
  • Info: I got the 2560x1440, progressive, 59hz and CVT-RB settings also with a standard HDMI cable (Windows 10, Intel HD 520)
    – sevenforce
    Aug 28, 2016 at 16:53
1

Well, it's about a different laptop, but for me, none of the xrandr modelines on this page worked. It turns out to be because Intel HD 4000 is limited to 225 MHz clockrate on HDMI, and the display I'm using wants 50-70 Hz vertical refresh.

So I suggest the general approach would be to:

  1. Find out the specific graphics controller on the laptop and try to find out the maximum HDMI clock rate. You can also do it by trying out what rates xrandr or the Windows drivers will accept.

  2. Find out what vertical refresh rate the display supports. This is usually specified in the manual.

Then it boils down to finding a video mode that fills both these constraints. There are several calculators for this, I used cvt_modeline_calculator_12 and ended up with:

./cvt12 2560 1440 55 -b # To generate the modeline below
xrandr --newmode "2560x1440_55.00_rb"  221.11  2560 2608 2640 2720  1440 1463 1468 1478 +hsync -vsync
xrandr --addmode HDMI1 2560x1440_55.00_rb

xrandr --output HDMI1 --mode 2560x1440_55.00_rb  # To apply

Which worked fine for me.

3
  • To make this apply I think you also need to do something like xrandr --output HDMI1 --mode 2560x1440_55.00_rb Mar 18, 2021 at 13:45
  • 1
    @DanGravell True, I'm not sure why I haven't put that in the answer also.
    – jpa
    Mar 18, 2021 at 14:36
  • Have an upvote :) Mar 18, 2021 at 16:09
0

Unfortunately, it looks like there are very few devices that can do HDMI output or input above 1080p.

A HDMI-to-DVI adapter seems to work, though: http://forums.whirlpool.net.au/archive/1479962

0

thx to this guide, now I can use my Dell U2711 with HP Laptop equipped with Nvidia RTX3000. Here's the tips:

  • open Nvidia control panel
  • verify that the correct Display is select
  • verify that the connector is HDMI
  • click "personalize" and set the resolution as you need
  • test and apply this settings enter image description here

that's it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.