0

I use a freesync monitor and when I run RDC to either my laptop or a hyper-v session I've noticed that freesync kicks in (borderless windowed mode) and will go between 30->60(doubled from LFC?)->75(my display refresh rate) and all over the place. I end up having to disable Freesync which is not ideal.

Is there something causing RDC to only refresh @ 30hz? The connection also feels very laggy even though it's either on my PC (Hyper-V) or right next to me (Laptop).

Is there a way to force RDC to at least run 60hz if not the full 75hz my monitor supports? I've tried both windows 10 anniversary and now also the latest creators update. Also I'm not sure if it's freesync causing the issue or not, because it does seem to lag even when disabled, just not as much. There is still a noticeable delay when typing (programming) sometimes which is an issue. Having freesync enabled just really highlights the issue because I can see the hz on the monitor's overlay swap between 30-60 constantly.

Monitor: ACER XR341CK GPU: AMD Fury Windows: 10

2
  • I think the proper solution would be to disable FreeSync for RDC, if that is at all possible. Maybe in your graphics driver’s application-specific settings?
    – Daniel B
    Apr 8 '17 at 17:17
  • @DanielB afaik there is no option to do so. I wouldn't mind just disabling it for all borderless windowed windows at this point if that was an option, but I haven't seen one.
    – John
    Apr 8 '17 at 17:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.