2

First I install Ms Visual Studio Community 2017 from oficial site. That Works fine.

Next I install Intel® Parallel Studio XE Cluster Edition (includes Fortran and C/C++) from Intel Developer Zone Site. At that site was a free offer the tool for students.

The installation was installed the next softwares:

Intel Parallel Studio XE 2017

But when I try to create a new Fortran Project I didn't find the option on the Visual Studio Community 2017.

New Project on Visual Studio Community 2017

Then I search on internet about this issue and I found this article:Troubleshooting Fortran Integration Issues with Visual Studio Which says:

If you are using Intel Parallel Studio XE 2017 (compiler version 17.0), Visual Studio versions 2012, 2013 and 2015 are supported.

So I tried to download the Ms Visual Studio Community 2015 but I can't. Microsoft web site only offer Visual Studio Community 2017 nowadays.

I want to build Fortran or C/C++ Project using Math Kernel Library or Blas, Linpack or Lapack. What can I do? Is there a way to resolve this integration issue, Should I find a VS Community 2015 or maybe Should I try GNU-GCC compiler but in this case how use the LINPACK?

  • 1
    There isn't a solution to your problem other than using VS2015 the package addon you downloaded doesn't support VS3017 – Ramhound Apr 8 '17 at 20:49
  • But How can I get the VS2015? I couldn't find on Microsoft web site visualstudio.com/vs/older-downloads – Adolfo Correa Apr 8 '17 at 20:58
  • I can't help with VS2015 but I have an answer with VS2013, ISOs for VS2015 still exist, but I got plans....superuser.com/questions/840295/… – Ramhound Apr 8 '17 at 21:13
  • @AdolfoCorrea same issue with me. Did you get any solution? – Micky K Oct 18 '18 at 3:26
  • Yes @MickyK , I have answered below what I did to "solved". You have to install one of the compatible version of VS with your Intel Parallel Studio. You must have a compatible version of Visual Studio and Intel Parallel. – Adolfo Correa Oct 19 '18 at 14:19
2

At that time, the solution was to install the VS Community 2015, like @Ramhound commented and after reinstalling the Intel Parallel Studio XE 2017. Currently, Intel Parallel Studio XE 2018 supports Visual Studio 2017.

But in the future, this problem could repeat then the next are steps for install the latest Visual Studio supported by the Intel Parallel Studio XE.

  1. First, check out the version of Visual Studio that is supported by the Intel Parallel Studio XE available. You can check at this site Troubleshooting Fortran Integration Issues with Microsoft Visual Studio*

  2. Install the Visual Studio supported by the Intel Parallel Studio XE that you're going to install. If the supported version of Visual Studio isn't the latest one, you can download a older version from VS older downloads

  3. Finally, install the Parallel Studio XE.

  • So basically what I suggested back in April :-) – Ramhound Sep 28 '17 at 3:04
  • Yes @Ramhound , In april I installed the VS2015. You have credits for that. I try to reference you, editing the answer... but the @ didn't work like in comments. – Adolfo Correa Sep 28 '17 at 13:16
0

According to Steve Lionel, AKA Mr. Fortran:

VS2015 Community DOES support Intel Fortran, and indeed I tested this exact combination just the other day. You do need to select a Custom install of VS2015 and check the box for Programming Languages > C++. If you didn't do that before, rerun the VS install, change the setting, then rerun the Parallel Studio XE install (2015 Update 4 or later) to select VS2015 integration.

If this doesn't help, you may need to locate where the Windows SDK was installed as part of VS and add its binary path to the Executables list under Tools > Options > Intel Compilers and Libraries > Visual Fortran > Compilers. On my system this is C:\Program Files (x86)\Windows Kits\8.1\bin\x64\rc.exe (for 64-bit) and C:\Program Files (x86)\Windows Kits\8.1\bin\x86\rc.exe for 32-bit

-1

You need to install this add-on at https://marketplace.visualstudio.com/items?itemName=ChuckPiper.vs-extension-17264 , should work for visual studio 2017. Haven't tried it myself 'cause I don't know any Fortran...yet.

protected by Community Nov 2 '18 at 7:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.