2

How can I get vim arrow keys to work inside a mosh shell? They used to work for me but after upgrading something (mosh probably) it's broken.

Arrow keys don't work

  • mosh 1.2.6 remote shell
  • vim 7.4
  • ubuntu 14.04

Workaround

:set term=builtin_ansi

but with this I lose my 256 color display. On a regular ssh session it works fine (where the value of term is xterm-256colors).

Works (I have this on another machine)

  • mosh 1.2.5 remote shell
  • vim 7.4
  • ubuntu 16.04
1

1 Answer 1

1

Not the direct answer to your question how to enable the arrow keys. But Vim standard to move is:

h – left
j – down
k – up
l – right

link for moving around in vim: http://vim.wikia.com/wiki/Moving_around

1
  • 1
    Yeah, that's what I'm resorting to right now. Commented Apr 11, 2017 at 6:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .