I have a VM with RHEL 5 without an X server. My host has Windows 7.

I need to connect to the VM and redirect the X11 output of the commands to my host.

I know that if my host were a GNU/Linux machine it would be as easy as ssh -X .

I'm using PuTTy to connect by SSH to the VM, I tried enabling X11 forward option in PuTTY config, but nothing happened.

Have you ever done this? I'm quite advanced with GNU/Linux, but a newbie with this toy of Winbug$ 7.

  • 1
    if you've enabled putty's X11-forwarding option, you're halfway there. that's all you need on the PuTTY side; RHEL is good to go; now you need an X server to display to. (Windows is not an X-server.) Cygwin and Xming both provide free x-servers for Windows, but i don't know how well they work on Win-7. there are commercial options as well. Mar 14, 2010 at 16:40
  • 3
    "I have a VM with RHEL 5 without an X server." you need an xserver of some sort to forward x.
    – Journeyman Geek
    Mar 15, 2010 at 3:21
  • Here is a decent guide in case the accepted answer isnt clear as to what you need to do with Xming/Xlaunch: seas.upenn.edu/cets/answers/x11-forwarding.html
    – dhaupin
    Oct 5, 2016 at 20:47

2 Answers 2


You need a X server on your windows workstation. A couple popular options include:

You need your SSH server to have the X11Forwarding yes set in the sshd_config. It also needs at least the xauth binary/package, but you may want to install your distrobutions version of X11 base clients.

In putty all you should have to do check the Enable X11 forewarding box under Connections\SSH\X11 in your putty connection.

putty x11 settings

Putty documentation for X11 forwarding

Man pages for sshd/sshd_config

  • 4
    Even though XMing shows me that it's display 0:0 on my system, when I filled in localhost:0:0 to the "X display location" field, the forwarding did not work. Just leaving this field empty is the best thing you can do ;) Nov 21, 2017 at 19:21
  • 3
    Note that Xming does work with Windows 10, although it's not specified on their webpage.
    – Joce
    May 25, 2018 at 7:59
  • @Joce.. Agree.. Xming is amazing.. even though its a bit old..
    – alpha_989
    Aug 5, 2018 at 16:50
  • You may need edit as admin: C:\Program Files\Xming\X0.hosts and add your VM IP address and restart xming. Oct 20, 2019 at 20:28
  • My 2 cents: I tried the above methods. With Xming/putty I needed to put the localhost:0.0 in my config. This document worked for my setup[aws.amazon.com/blogs/compute/…
    – Marinaio
    Oct 12, 2021 at 13:52

you could use MobaXterm against the putty. https://mobaxterm.mobatek.net/download.html

  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Dec 18, 2021 at 9:36
  • Agree - MobaXterm was a quick solution, since Xming seems quite old and is not free to use (if one does not use it on a regular basis). Download, install, start SSH connection, then call the application. Note: there was a font-related error, so on the Host, set: export LC_ALL=C. Should do the job. Also, make sure that in /etc/ssh/sshd_config, X11Forwarding yes is set.
    – Ingmar
    Sep 19, 2022 at 10:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .