I have an external hard disk where I have created many partitions to use also in Linux.

First two partitions are FAT32. The third is a Truecrypt partition. I cannot assign a letter to the second partition.

When I go to Manage disk and right-click on the unassigned partition, most of the options are not enabled.

shot of the partitions

What have I to do to see this partition on my XP PC?

  • Could you provide a more complete screenshot? The listview above the area you showed provides more information, and the items don't get cropped due to limited width. – Hugh Allen Mar 22 '10 at 6:46

Windows only supports one active primary partition at a time, and by the looks of it you have three primary partitions and an extended partition containing 8 secondary partitions.

One of your primary partitions is active and allocated to drive letter I: so the other two primary partitions are inaccessible to windows.

Since Truecrypt is obviously happy with it's volume being a primary partition (which conveniently also hides it from Windows), I would be inclined (after backing up the whole drive several times) to remove the 2nd primary partition, move the truecrypt volume to be next to the active primary (I:) partition, expand the extended partition to fill the hole left by the truecrypt partition and re-create the 98GB FAT32 partition in the new space in the extrended partition. At this point you should be able to format it, allocate a drive letter and copy the data back into it.

  • Yup, the partition in question is set as active. That’s the problem. You may be able to use a third-party partition manager to simply remove the active flag (otherwise it will require more work like moving partitions around). – Synetech Apr 6 '10 at 0:24

Have you tried another disk manager? I use EASEUS Partition Master, home edition is free. You can change drive letter in the Advanced menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.