2

I have a Windows 10 computer. This morning it restarted into a blue screen with error code Inaccessible boot device.

There are no recent hardware changes. Also I think it was not after a Windows update installation. At least I chose Restart to restart, and not Update and restart as usual before an update installation.

According to other posts related to this problem I tried the following:

  • Restart into save mode: no success, the same error displays
  • Restart into recovery console: The system partition usually mounted as C: is available as D:
    • chkdsk d: /x completes without finding any error. I conclude, that the problem is not related to a hard disk failure.
    • bootrec /fixboot completes with success.
    • bootrec /scanos completes with a message Number of Windows installations identified : 0. Why doesn't it find the Windows installation, even though it is available under D:\ ?
    • sfc /verifyonly has found integrity violations, but sfc /scannow finished with the message The Windows resource protection was not able to complete the operation.
  • System restore to a previous restore point: After a (long) while, the task completed, but without solving the problem.
  • Booting from the Windows Installation disk:
    • I tried the option Repair Windows: It was not possible to roll back to a previous restore point
    • Update Windows keeping programs and files seems to work only when booting first into the current installation to do an upgrade. It cannot be done while booting from the installation disk (as it was the case in previous versions of Windows).

Is there anything left I could do before reinstalling Windows 10 ?

Edit: Now there is the second computer with the same problem within 2 days. This smells like an epidemy (caused by a bad Windows update ?)

This time I tried:

  • Restart into save mode: no success, the same error displays
  • System restore to a previous restore point : No success, it offers to try from another restore point.

I stopped here. I just don't want do make a mistake that forces me to reinstall it.

1

We have the same issue since last week. Multiple computers with inaccessible boot device. I used DaRT to uninstall KB4015217 on some PC's, that fixed the issuse. The update does not appear on all PC's. Do you use F-secure as Antivirus?

6
  • We are using ESET as antivirus. Du you think it is related to the Antivirus ? – Lorenz Meyer Apr 18 '17 at 13:40
  • Myself, I disables the Windows Update service on the PCs potentially affected, and did not yet go further. For the two PC that were dead, I reinstalled Windows on one of them and upgraded immediately to Windows 10 1703, that did not seem to be affected. The other is still dead. – Lorenz Meyer Apr 18 '17 at 13:43
  • No, i did some more research. It is the KB4015217 update that creates this problem. I found this article on reddit: reddit.com/r/vmware/comments/65ws15/… Going to try this. – Lars Kremers Apr 18 '17 at 13:46
  • I have Software Assurance for my Windows 10 Licences, but I cannot find any information on how to get DaRT. I feel like this fellow: disq.us/p/169bq6h. "What M$ crap! they kill our PCs, let us clean up afterwards; they have some tools to fix it, but there's no information on how to get them." :( – Lorenz Meyer Apr 18 '17 at 13:59
  • I used this website: thepc.tech/2016/06/windows-10-dart-10-x64.html – Lars Kremers Apr 18 '17 at 14:01
3

I recently ran into the same issue, but it was applicable to a different KB. I stumbled across the technique in this post which explained how to use DISM to uninstall the most recently dated updates. I was able to sequentially remove two updates, one pending removal and one pending update, and another which was installed the day prior. After restarting the system, it booted right into Windows 10.

The basic process is to boot from a DVD/USB and select the repair options until you get the command line. Then run DISM command below replacing C:\ with the drive letter Windows is installed on (if required).

Dism /Image:C:\ /Get-Packages

You can then replace the package name into this command and it will attempt to remove them.

Dism /Image:C:\ /Remove-Package /PackageName:Package_for_KB######

I had to try the couple of the more recent package names to find the right one to remove first. Copy and paste works in this command line, which makes it easier.

2
  • Just noticed this is the same link Lars Kremers posted in his comment, so this answer is just bringing the external content in to SU. – Melikoth May 16 '17 at 19:40
  • This is interesting for the next time. I tried exactly these command lines, but I got an error. If I remember well, it was about permissions. – Lorenz Meyer May 17 '17 at 7:09
2

Make sure you did not switch from MBR to UEFI boot system or vice-versa.

If that's not it, then reinstall.

3
  • Finally, I reinstalled Windows. I chose to install it in the same partition as the previous installation, keeping the old files in Windows.old. This allowed me to be back and running in about two hours and a half. A pretty short time. – Lorenz Meyer Apr 11 '17 at 21:01
  • That's good; take whatever you still need from the old install then do a clean-up. – Overmind Apr 12 '17 at 5:20
  • I removed the 'accepted answer' tick, because I'm just having the second case, and I don't want to end up with reinstalling it too. – Lorenz Meyer Apr 12 '17 at 8:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.