3

I have a Windows 10 machine that changes the desktop background on its own. I have the background set to solid color but after a few minutes it changes to a random picture. When I go back to the theme settings it is set to an unsaved theme with a background picture. I have sync turned off. What spell am I not aware of?

6
2

What spell am I not aware of?

You need to disable the Desktop Background Slideshow:

  1. Write Control Panel in the Start menu Search box and click on Control Panel in Search result.

    enter image description here

  2. Click Power Options link in Control Panel.

    enter image description here

  3. Tap on Change plan settings link which resides just beside your chosen power plan.

    enter image description here

  4. Hit on Changed advanced power settings link to open the new window entitled Power Options.

    enter image description here

  5. Double Click Desktop background settings to expand it downward and open a new option named Slide Show.

    enter image description here

  6. Double click on Slide Show. You find here links Paused or Available in On Battery and Plugged conditions.

    enter image description here

  7. Here you need to change the setting as per your need.

    • If you want to enable Desktop background slide show then change both links to available and if you want to disable change the links to Paused.
  8. If you need to customize it according to the power whether it is electric power or battery you can do this from here.

    • On battery – Paused to disable Slide Show.

    • On battery – Available to Enable Slide show.

    • Plugged in – Paused to disable Slide Show.

    • Plugged in – Available to Enable Slide Show.

  9. Finally, click on Apply and OK.

Source Windows 10 – How To Enable/Disable Desktop Background Slide Show

1
  • I had seen that page and tried it. No change. – user717108 Apr 10 '17 at 17:11
0

So the problem was a theme that could not be disabled. Somehow I installed a dynamic theme that would not respect settings. To fix it I did this:

WARNING: THIS REQUIRES EDITING THE REGISTRY. PROCEED AT YOUR OWN RISK.

  1. Wait until a picture is displayed on the desktop
  2. Go to the theme settings to find the filename of the picture
  3. Use regedit to find an instance of the picture name (it will be in a Wallpaper key). Note the folder that picture is in ($USER/Local/AppData/Packages/...).
  4. Use regedit again to find the that folder name in the registry (In my case "Lavalle" was part of the name).
  5. It will show up in the registry in a list of windows background processes.
  6. Delete that process key in the registry.
  7. Restart your computer.

I believe this will keep the errant theme process from running. Be very very very careful in dealing with the registry. Make edits at your own risk.

-1

Sometimes, when you initially upgrade to Windows 10 or install any feature update of Windows 10, your desktop background settings may get messed up, and all the new modifications you make in order to fix them stay only until a reboot or a shutdown.

  1. Open RUN Command
  2. Type powercfg.cpl and hit Enter
  3. For your selected power plan, click on Change Plan Settings.
  4. click on Change advanced power settings.
  5. Expand the option that says Desktop Background Settings. Next, set the slideshow to be Disabled or Paused for both the scenarios: On Battery and Plugged in.
  6. Reboot your PC.

You can also check the other solutions here: https://www.techzac.com/desktop-background-changes-itself-windows-10/

1
  • 1
    If they are relevant, you should edit your answer to include those other solutions; external links can change or disappear. – bertieb May 23 '18 at 13:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.