0

1. Summary

If I run Grunt commands in ConEmu, sometimes my output foreground = background.

Else I run any another CLI commands in ConEmu, I can't reproduce this bug.


2. Environment

  • Windows 10 Enterprise LTSB 64-bit EN,
  • ConEmu 180206 [64] Alpha,
  • Far Manager 3.0 (build 5151) x64,
  • Node.js 9.7.1,
  • grunt-cli v1.2.0,
  • grunt v1.0.2,
  • grunt-hello-world 0.1.0.

3. Project

See example project configuration in branch SashaFarColors of my repository.

For example, I use simply grunt-hello-world plugin, that print «Hello world!».

My Gruntfile.coffee file:

module.exports = (grunt) ->

    grunt.loadNpmTasks('grunt-hello-world')

    grunt.initConfig

        hello_world:
            world:
                name: "world!"

4. Steps to reproduce

  1. I install latest portable ConEmu version,
  2. I remove Far Manager → I remove all data from %USERPROFILE%/AppData/Local/Far Manager and %APPDATA%/Far Manager → I install Far Manager.
  3. I print in $terminal:

    grunt hello_world
    

5. Expected behavior

If terminal == Hyper for Windows in Far mode:

Hyper


6. Actual behavior

Else terminal == ConEmu in Far mode:

ConEmu

Log (SettingsFeatures → I put a mark to Log console output):

Far Manager, version 3.0 (build 5151) x64Not enough memory is available to complete this operation.Press <kbd>Enter</kbd> to retry or <kbd>Esc</kbd> to continue…
D:\SashaDemoRepositories\SashaGruntDebugging>grunt hello_world
[4mRunning "hello_world:world" (hello_world) task[24m
Hello world!

[32mDone.[39m

7. Not helped

I try to change:

  1. color scheme,
  2. another different ConEmu settings.
  • To be sure, we need Ansi Log of the command. – Maximus Apr 10 '17 at 23:32
  • @Maximus, SettingsFeaturesI put a mark to Log console output. Is it «Ansi Log»? If yes, screenshot and log. Thanks. – Саша Черных Mar 5 '18 at 17:23
  • In the log I don't see bg/fg change requests. That meens some application (I don't know what exactly: Far/Node/Grunt) changes bg/fg via Window API. To go further I need sample repo to run grunt command and exact version of the Node. – Maximus Mar 5 '18 at 23:31
  • @Maximus, I overwrite a question. I add example simply repository and versions of my environment to new question revision. // Also, see section 5: if I run Far Manager via Hyper, I can't reproduce the problem. Thanks. – Саша Черных Mar 6 '18 at 8:26
  • @Maximus, Status: Fixed for me in ConEmu 180422 [64]. Please, add an answer, that I could raise your reputation. Thanks. – Саша Черных Apr 27 '18 at 7:15
1

The problem was fixed in build 180309.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.