9

I have found that after installing the Windows 10 Creators update on 2 machines so far, the desktop icon spacing is such that there is a massive gap between icons at the bottom of the desktop and the taskbar.

Here is the spacing pre-upgrade:

Pre-upgrade

Here is the spacing post-upgrade

Post-upgrade

Note that those images are exactly the same size and resolution, so you can see that the desktop grid has changed.

Here they are side by side:

Pre-upgradePost-upgrade

I have tried things like changing the icon size, but it doesn't help, as I suspect the grid itself has changed meaning that is as low as it will go.

I know it's only a minor thing, but it makes the desktop look a little silly, and turning off align to grid has the potential to look even worse.

I don't think it has anything to do with small taskbar icons, but might be related to double height taskbar, as turning that off, the gap is much reduced.

Does anyone know how to fix this positioning so it goes back to how it was before the install of the creators update?

  • Yeah, i have that problem as well, the temporary solution i found was holding Ctrl + Scroll to make the icons i little bigger, but i want a real fix – Dark Survivor Apr 11 '17 at 20:32
  • I have the same issue, although instead of the gap at the bottom, I lost an entire column on the left side of my screen. Every time I move an icon into that column as soon as I click off the icon it reverts back to it's previous position. – Gansheim Apr 12 '17 at 1:52
  • Please update if you find a solution. It's really annoying. – yuriy636 Apr 13 '17 at 19:11
  • I'm seeing the same thing as hamiheim. My dell 5510 has a 4K display, btw. – Darr247 Apr 18 '17 at 16:21
  • Can't put icons in the top left, bug in the new update – jjxtra Jun 28 '17 at 18:18
2

It can be fixed by changing some registry values. Go to this location in regedit :

HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics

You will find keys named IconSpacing and IconVerticalSpacing.

To solve this problem you need to increes the value of IconVerticalSpacing.

(You can also play around with the IconSpacing value to increase horizontal gap between icons.)

By default,the values of both IconSpacing and IconVerticalSpacing is -1125 in Creators Update and in previous versions too.*

*(In 1366x768 resolution and 100% scaling.)

You need to change the IconVerticalSpacing value to -1200 and then sign out and log in again,and it will be same as previous version.

Proof :

IconVerticalSpacing's value is -1200

P.S.

You can also use Winaero Tweaker to change the icon spacing with a nice user interface.

enter image description here

  • Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places. – DavidPostill Jun 19 '17 at 11:13
  • Okay ,got it :) @DavidPostill – SSAURABHH Jun 19 '17 at 11:50
  • Wahoo! It worked when I used WinAero tweaker. Note, for 1280x1024, I had to use a value of 78 rather than 80! Thanks – Eds Jun 27 '17 at 12:27
  • Didn't work for me 1920x1080 – insidesin Jul 28 '17 at 5:18
2

Currently, holding CTRL and scrolling is the closest solution. I found this to work absolutely fine.

  • I think the problem with this is, it isn't fully effective when using a double height task bar and small icons. The gap is reduced due to the icons taking up slightly more space, but for me it only reduces it by a small number of pixels. – Eds Apr 18 '17 at 13:47
  • Apparantly, the icon sizes for small/medium/large icons have been changed in this update. The cause is, I think, the grid is being calculated using the new values, while the icons are rendered using old sizes. Changing the icon size by Right_Click -> View also works. – asif May 21 '17 at 9:42

protected by Community Apr 12 '17 at 1:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.