My system: Windows 10 Home

Drives: WD and Seagate 4TB USB 3.0 external hard drives

Several days ago, I bought a Western Digital Passport 4TB USB 3.0 external hard drive. I plugged it in and did something I never do: installed the included software, including diagnostic and backup utilities. Drive worked fine. Later that day, restarted the computer and the drive no longer showed up. Not in Explorer, not in disk management.

In the device manager, the drive doesn't show, but under "USB Serial Bus controllers" there are two devices with the yellow exclamation point triangles, "Unknown USB Device (Device Descriptor Request Failure)" and "Unknown USB Device (Link in Compliance Mode.)" Also should mention that these incompatible devices only show up at all when I start the computer with the hard drive plugged in, do not show up when I plug in when the computer is on. Literally nothing happens when I plug the hard drive in when the computer is on, except that the LED on the drive lights up.

I went into the event viewer and there is a "Device could not be migrated" Kernel PnP error 441. Here's the XML output for the event:

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <Provider Name="Microsoft-Windows-Kernel-PnP" Guid="{9C205A39-1250-487D-ABD7-E831C6290539}" /> 
  <TimeCreated SystemTime="2017-04-08T16:49:36.610151400Z" /> 
  <Correlation /> 
  <Execution ProcessID="4" ThreadID="5680" /> 
  <Security UserID="S-1-5-18" /> 
  <Data Name="DeviceInstanceId">USB\VID_0000&PID_0002\5&2df8dc4a&0&1</Data> 
  <Data Name="LastDeviceInstanceId">USB\VID_413C&PID_2003\5&37cfed4b&0&3</Data> 
  <Data Name="ClassGuid">{36FC9E60-C465-11CF-8056-444553540000}</Data> 
  <Data Name="LocationPath" /> 
  <Data Name="MigrationRank">0xf000fffffffff120</Data> 
  <Data Name="Present">false</Data> 
  <Data Name="Status">0xc0000719</Data> 

I tried multiple hours of fruitless solutions (which I list below.) I also bought a Seagate Backup Plus 4TB drive in hopes of just returning the other drive. No dice, it also doesn't show up. Both drives work just fine on other computers. Also, frustratingly enough, a USB thumb drive shows up just fine.

What I've Tried:

  1. Making hidden devices visible, uninstalling the old devices, restarting
  2. Tried updating drivers
  3. Scanned for hardware changes
  4. Did a windows update
  5. Updated BIOS
  6. Safely ejected the drive from another computer
  7. Tried a different set of cables
  8. Used WD drive utilities and Seatools
  9. Set Windows Services to Automatic: Computer Browser, Plug and Play, Portable Device Enumerator Service, SSDP Discovery, Storage Server, UPnP Device Host, Virtual Disk, Workstation, WD Drive Manager
  10. Went to disk management, no drive to see there
  11. Changed USB root hub power controls, disallowed computer to turn off device to save power
  12. Changed power settings, turned USB Selective Suspend off
  13. Turned off Fast Startup
  14. Uninstalled all USB Controllers, restarted
  15. Used Microsoft FixIt for devices
  16. Used Microsoft Troubleshooting for devices
  17. Uninstalled all of WD's software
  18. Turned off my anti-virus
  19. Probably a dozen other things I've forgotten

I'm at my wits end here. Any help is appreciated.

Addendum: I've also gotten a 411 "Device had a problem starting" error. Could add the XML if needed but feel like this post is too long already.

Also, am buying a Y-splitter off Amazon.

  • Information about the hardware would be helpful. What is the computer make / model? – Jaxian Apr 11 '17 at 15:03

I recently had a very strange USB-related problem in Windows 10, and after a lot of fighting I realized the culprit was a corrupted registry.

You could try to perform an automatic repair on your registry: https://neosmart.net/wiki/fix-registry/#Run_Automatic_Repair-2

Also, try to repair other corrupted system files with sfc /scannow via command line. Instructions can be found here: https://www.howtogeek.com/222532/how-to-repair-corrupted-windows-system-files-with-the-sfc-and-dism-commands/

  • Did the problem you have include the same symptoms OP notes in their question? Also, can you include the pertinent steps from the registry fix link as a blockquote? – music2myear Apr 11 '17 at 17:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.