6

I wanted to change the default of encoding in Notepad (ANSI) to UTF-8. According to following link went ahead and this work was done.

But still remains a problem. If create a text file, the default encoding is UTF-8 but if open the Notepad from Windows start menu's search, the default encoding of that is the ANSI.

Is there way for second mode that change the default encoding to UTF-8?

5 Answers 5

3

UTF-8 is now the default mode in Notepad since Windows 10 1903

2

Note

Firstly first I recommend you to simply use Notepad++ as a text editor or VSCode if you want a more developed one.


Explanation

But if you still wanna use Notepad for some reason, here is the way :

  1. Right click on Desktop, then choose New > Text Document
  2. A text file New Text Document.txt is created. Don't type anything and open it.
  3. Go to File > Save As... and choose UTF-8 under Encoding:, press Save and overwrite the existing file. Close the file.
  4. Rename New Text Document.txt to TXTUTF-8.txt
  5. Copy "TXTUTF-8.txt" to C:\WINDOWS\SHELLNEW
  6. Go to Start > Run... and type regedit and press ok
  7. Navigate to HKEY_CLASSES_ROOT\.txt\ShellNew
  8. Right-click in the right window > New > String Value and rename it to FileName
  9. Double click on FileName and put TXTUTF-8.txt into Value data: field and press ok

Remember, whenever you want to open a blank utf-8 txt document you will have to right click > New > Text Document and work from there.

Modifying the registry can cause serious damage pay attention, please.

Source

From this thread.

Here is the Microsoft answer too

0

The solutions given at Microsoft forum involve either by creating a shortcut to a blank utf8 document, or opening a blank document from the context menu (by editing the registry & selecting New Text Document from 'New' menu).

Without going through the steps involved in setting up the above solutions (which does involve quite a few steps), I've come up with this one line code to type into Win CMD, giving a utf8 document containing one utf character in it (The utf char makes sure Windows saves it as utf8; can be any utf8 char with encoding above 0x127).

This character can be deleted before beginning/editing the document, and by default will be saved as utf8.

chcp 65001 & echo ♪>test.txt & notepad test.txt

Tested in Win 10 CMD

-2

It's right in the Menu:

File > Encoding > Default

enter image description here

1
  • There is no such thing in Notepad. Where did you get this screenshot from? Maybe you added something to your Notepad?...
    – TheCuBeMan
    Jun 1, 2021 at 8:29
-3

Open Notepad. Go to 'format', 'font' and change 'script' to 'Central European'. Simple.

1
  • 5
    Does central european necessarily mean UTF-8?
    – Journeyman Geek
    May 14, 2017 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.