1

I have installed xpra from the ubuntu repos (16.10). I also have installed websockify. When I try to use it to set up an html5 session with the following:

xpra start --bind-tcp=0.0.0.0:14500 --html=on --start-child=xterm

I get the following error:

xpra initialization error:
 failed to setup websockify html server: cannot find xpra's html directory
 (not found in '/usr/share/xpra/www')

and I am currently stuck. Any suggestions?

I am attempting to make xpra provide X applications remotely over the web, using Ubuntu (16.10). This should be easy from everything I have read.

3
  • Which version of xpra? From which repo? Try the packages from xpra.org instead.
    – totaam
    May 19, 2017 at 15:46
  • 1
    I did, and it worked. As I said, it was xpra from the Ubuntu 16.10 repo. It apparently was missing some dependencies.
    – Cliff Hill
    May 19, 2017 at 16:42
  • 1
    I had similar issues with the Ubuntu 18.04 prepackaged binary. Switching to xpra.org's repo solved the issue for me.
    – joat
    Dec 30, 2019 at 12:15

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.