11

I decided to allow the Windows 10 Creator's Update and noticed one significant change. For work reasons, I need to have my firewall off (it's connected to a domain, where the firewall is). It's a long story. In any case, I'm noticing that I'm getting an alert that the firewall isn't activated, but I can't seem to find a way to turn off that alert.

See screenshots below.

I also tried "advanced settings", which didn't appear. Perhaps one more bug that needs to be addressed. In any case, how can I disable that specific firewall warning?

enter image description here

enter image description here

3
  • Windows actually has always notified you of this fact. The only difference is the security alerts, like this notification, are all being reported within the Windows Defender UI now. No; Unless you are getting actually notification windows, you can't disable the reporting, unless you install a third-party firewall or enable Windows Firewall.
    – Ramhound
    Apr 13, 2017 at 19:40
  • 1
    Prior to CU, there was an option to shut off warnings about the various system settings. Now, there is not. (at least, not an obvious option)
    – Eric Blade
    Apr 16, 2017 at 4:11
  • I'd just like to take a moment here to point out that this question implies some VERY bad things about your corporate (and possibly personal) security. Even if your machine is only ever connected to the Internet through the corporate firewall (which merely being domain-joined does not guarantee), it's still very, very important to protect the machines individually. If you don't do that, then any attack which manages to get past the perimeter firewall can spread unimpeded across your network! You should always have security at multiple layers, NOT just at the periphery.
    – CBHacking
    Jan 11, 2018 at 2:33

5 Answers 5

4

Before the Creator Update, I was able to go into the Firewall setting and select that I didn't want to be warned about not having a PC-level firewall. If Microsoft will never allow one to disable any warnings in Windows Defender, then my next option is to go to taskbar settings and set the Windows Defender Notification Icon to off. I don't have the warning icon staring at me anymore.

The downside of this approach is that while it effectively hides the firewall warning, it also hides any other legitimate alerts that have nothing to do with the firewall.

enter image description here

3

Go to Task Manager>Startup and disable Windows Defender notification icon. Restart and it should be gone. You will still see the notification if you open Win Firewall settings, but at least it won't be on the task bar.

1
  • Welcome to Super User. Regarding your comment "If anyone knows of a group policy to totally disable this icon", instead of posting this in your answer please ask your own question if you wish to pursue this. May 12, 2017 at 13:31
3

Source: Disabling Windows 10 Notifications via Group Policy I've been looking for an automated solution to disable the Firewall notifications for over 6 months using the registry (because Win10 Home doesn't have Group Policy), that I lost all hope in Win10 and it's developers.

To disable the Firewall notifications, I used string Disable Security and Maintenance Notifications with the following DWORD set to 0:

HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Notifications\Settings\Windows.SystemToast.SecurityAndMaintenance\Enabled
1
  • Works as advertised, no more firewall warnings. Mar 3, 2018 at 9:57
3

The easiest way its to create a custom inbound rule that allows "Everything" in advanced settings and you still receive notifications you may want.

To create an inbound rule

  1. On the computer that is running the Windows Firewall, on the Start menu, choose Control Panel, choose System and Security, and then choose Windows Firewall.
  2. In the navigation pane, choose Advanced settings.
  3. In the Windows Firewall with Advanced Settings window, in the navigation pane, choose Inbound Rules, and then in the Actions pane, choose New Rule.
  4. On the Rule Type page, choose Custom, and then choose the Next button.
  5. On the Program page, choose All programs.
  6. On the Protocol and Ports page, choose Any.
  7. On the Action page, choose Allow the connection.
  8. On the Profile page, choose the profiles, and then choose the Next button.
  9. On the Name page, type a name for the rule, and then choose the Finish button.
4
  • Control Panel didn't have any options named "System and Security". I have "Security and Maintenance" and "System". Neither option had "Advanced Settings." Apr 19, 2017 at 16:17
  • You have changed the default view of control panel from category to icon. From that view select "Windows Firewall" and skip to step 3.
    – Andarxx
    Apr 20, 2017 at 16:38
  • Switching to category view, I was able to follow your steps, but it did not alleviate the symptom in the Windows Defender Security Center (see the screenshot in my question). Is there anything after that step that alleviates the symptom I mentioned? Apr 20, 2017 at 21:00
  • @RandomHandle You actually have to turn Windows Firewall back on for this to work -- Windows then is happy because it's on, but since you're allowing everything through it's essentially off. This is the best solution to effectively have Windows Firewall "disabled" without the Windows Defender Security Center yelling at you. I wish they had let you choose to ignore it like with the Security and Maintenance notifications though.
    – Herohtar
    Jun 3, 2017 at 0:05
2

To get that shield to go away, go into the registry and delete the key in this screenshot:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\SecurityHeath
3
  • It appears you were speaking literally: this action deletes the shield icon in the taskbar. However, it does not allow one to disable the Firewall warning alone. Apr 27, 2017 at 16:13
  • Although it doesn't really answer the question it works flawlessly to get rid of the security center shield icon. Mar 3, 2018 at 9:57
  • @embracenext You have a typo in your registry key, the "l" in Health is missing.
    – PeterCo
    Dec 14, 2018 at 12:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .