9

For those who don't know, Microsoft released a major update to Windows 10 and one of the changes is that PowerShell replace cmd.exe by default. So e.g. when you open Win+X menu you see PowerShell links and no Command prompt anymore.

Anyway when running PowerShell I get this now:

http://i.imgur.com/KGdZKiI.png

This wasn't happening before the update.

EDIT: Changing font helps, but doesn't solve the issue for applications that does not have a feature to change font. The broken font is Terminal. Replacing it from other source/reinstalling or resetting fonts to default in control panel does not solve.

E.g. opening new fresh copy of Terminal fonts on desktop still doesn't render them, it shows hieroglyphs. So it's like not the font itself is broken, but something in Windows that does not render the font?

Also you can't reinstall .net framework 4.7 on Win10 there is no uninstaller, it ships with windows, all you can is delete dirs, tick/untick in programs and features, maybe run cleanup utility, but doesn't solve the font problem.

  • I'm running Creator's update build 15063.138 (15063.rs2_release.170317-1834). I don't see this issue but my locale is "English (India)". I still have "Command Prompt" under Win+X though and I can run both cmd.exe and Powershell. However, pressing Shift+AppsKey with any folder selected gives me "Open PowerShell window here". Interesting... – Vinayak Apr 23 '17 at 11:13
3

Microsoft fixed it for Creators Update 1703 with Update KB4020102 (OS Build 15063.332).

Addressed issue where some non-Unicode fonts (Courier, MS Sans Serif, etc.) do not render characters correctly on non-Latin, single-byte system locales (Greek, Hebrew, Arabic, etc.). Black bars or other artifacts appear instead.

This should fix your issue, according to a Microsoft employee which replied to an user on twitter who had the issue.

So open Windows Update and install the update to fix the issue.

5

The problem is not as bad as it seems. It seems like a problem with a font, which can be fixed by changing the font.

To do that, do the following.

Click the upperleft icon on the Powershell window (the powershell icon) and choose properties.

Go to the tab Font and change it to something else, for example Ludica Console

Press OK. Problem should be fixed.

  • 1
    You're right, the broken font is "Raster Fonts". Changing to any other font fixed. But I'm also going to perform what's in @Overmind comment. – user3108268 Apr 14 '17 at 9:16
  • sorry have to deselect this, the actual broken font is Terminal font and needs to be fixed. – user3108268 Apr 21 '17 at 7:38
  • 1
    this is a bug and MS fixed it in a patch – magicandre1981 May 27 '17 at 8:41
3

It happened before. An update affected a MOF file in the build package, the update breaking PowerShell DSC.

The ASCII chars are proof of DSC corruption.

Uninstall and reinstall .net Framework. Also, The .NET framework repair tool may fix the issue. you can get ithere

A SFC scan should also be performed.

If those don't fix it, we'll probably have to wait for an official fix.

  • Repair tool doesn't fix. sfc doesn't fix. can't uninstall or install .net framework 4.7 because it is built-in and ships with latest win10. – user3108268 Apr 21 '17 at 8:32
  • I know reinstalling it is not easy, but try alternate methods. In my latest scenario cleaning the cache files from Microsoft.NET/Framework64/v4.0 solved a similar issue. You could move the files somewhere and try the repair tool to see if there is any difference. – Overmind Apr 24 '17 at 6:52
  • this is a bug in the fonts and Microsoft fixed it in a patch – magicandre1981 May 27 '17 at 8:41
3
+50

Don't bother trying to fix it, it's not a problem in your specific installation, it's a known bug in Windows 10 Version 1703 Build 15063 (Creators update).

You can workaround it by changing the the font used in PowerShell for example as suggested or "fix it" globally by changing the OS non-Unicode setting to English.

A proper solution will only come when Microsoft will release a bug-fix for it. More Details on Microsoft forum

Update: Fixed in the Microsoft insider Fast ring (Version 1703 Build 16193.1001), probably will be released soon to the general public. If you want you can try this fix in the meantime that installs the fixed file https://github.com/ili101/Windows-10-1703-Non-Unicode-Workaround/tree/master

Update 2: Was fixed in May 25, 2017—KB4020102 (OS Build 15063.332) Just run windows update

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.