Whenever I plug in a USB flash drive, Windows 10 insists on creating the folder "System Volume Information." I really don't need this for a USB flash drive, especially if I'm planning on using this in my car's sound system, which is organized by artist as each folder's name. If I Google the title of this question, I get several hits, most of which are nearly identical to the one on The Windows Club. In Windows 10 AU this doesn't work, as another step is necessary, though it's my understanding it does in Windows 7 / 8 / 8.1. I'm unable to verify first hand.

  • 1
    It stores your restore points, and you can eliminate it if you delete all of them and turn off system protection. But if you do that you had better have a good backup system of your own in place.
    – SDsolar
    Commented Apr 15, 2017 at 8:52
  • @SDsolar, you're absolutely correct; system restore points are stored in the System Volume Information folder, but there's no reason to have one on a USB thumb drive.
    – BillDOe
    Commented Apr 16, 2017 at 20:06
  • System restore is controlled individually by drive letter. So if you don't want them on your thumb drive go into the system protection menu, delete them then shut it off for that drive.
    – SDsolar
    Commented Apr 16, 2017 at 23:16
  • 2
    I have done that, and while it does prevent creation of system restore points for the drive in question, it does not prevent creation of the System Volume Information folder, which contains many other objects besides system restore points (e.g. WPSetings.dat).
    – BillDOe
    Commented Apr 17, 2017 at 23:55
  • 1
    Same results here. It is disabled yet there are a bunch of files in there. With an administrator CMD I can use rmdir /r/s "system volume information" but I want it not to come back. And as for Windows Club, Adblock is telling me it is blocking 15 items, and the page pops up like Forbes.com to prevent me from seeing it. No way will I whitelist it with that many trackers.
    – SDsolar
    Commented Aug 14, 2017 at 18:14

5 Answers 5


I really wanted to get this solution in one place so that anyone else looking for it can find it.

From The Windows Club:

Step 1:

Using GPEDIT to modify Do not allow locations on removable drives to be added to libraries setting:

  • In Windows 10 / 8.1 Pro & Enterprise Editions, press Windows Key + R combination, type put gpedit.msc in Run dialog box and hit Enter to open the Local Group Policy Editor.
  • Navigate here: Computer Configuration -> Administrative Templates -> Windows Components -> Search
  • In the right pane, look for the setting named Do not allow locations on removable drives to be added to libraries and double click it.
  • Click on Enabled and then click Apply followed by OK. Close the Local Group Policy Editor.

  • If you cannot change this setting via gpedit.msc, then you'll need to make the change in the registry. If you are not comfortable doing so, please do not attempt. Open regedit from Run. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows. Locate the key DisableRemovableDriveIndexing. If it does not exit, create it by right clicking the right pane, select New > Key and make the key a DWORD Value. Double click on the key (or right click and select Modify) and change the value to 1 and select Ok.

    Step 2:

    For Windows 10 this additional step is necessary. Go back to Run, type services.msc, click OK. In the right pane scroll down to Windows Search, double click it and in Startup type: select Disabled. Click OK and then close. Just to be safe reboot.

    I have done the above and now whenever I insert a USB flash drive, Windows does not create a "System Volume Information" folder. However, it does create this folder for USB hard drives, which is exactly what I wanted. As far as I can tell Windows search still works, but I do not know how this setting affects Cortana, as I do not use it (don't even have a microphone). I tried to find the website where I originally found the second part of this but can't seem to. It doesn't come up again on a Google search.

    It's been my experience with Windows that what works on one person's machine may not on another's. Putting your machine back the way it was should not be difficult. And there's always the possibility that you may have a Local Policy setting that prevents these changes.

    This solution does work in Creators Update. The problem I experienced was due to the loss of my c:\users > d:\users junction that I lost during the Creators Update installation. Once I reestablished it, Windows stopped creating the "System Volume Information" folder upon inserting a USB flash drive. Sorry for the confusion.

    • 3
      It's incorrect registry path. One more key level "Windows Search" should be there actually containing DisableRemovableDriveIndexing value (NB: the latter is a value, not a key, don't mix up these two concepts!)
      – Van Jone
      Commented Aug 8, 2017 at 11:15
    • Does not work, with either configuration. Folder keeps getting created by windows.
      – marcolopes
      Commented May 31, 2021 at 22:16
    • ok, there is only one file that keeps being created: tracking.log (i wonder what it is and how can i prevent this file from being created)
      – marcolopes
      Commented May 31, 2021 at 22:42
    • FOUND the culprit! It was the "Distributed Transaction Coordinator" service! Disabled now, and no SVI folder getting created.
      – marcolopes
      Commented May 31, 2021 at 23:30
    • IIUC, this is not a solution. If you disable Windows Search service then the search still works. But new/changed content is not indexed, on all drives. Which is not what most users want Commented Aug 15, 2021 at 15:02

    Bill Oertell's solution is missing one crucial step; at least this step is necessary with the latest version of Windows 10. I'm adding that step here, so that there is a permanent record of the full solution.

    You should do everything he advises, but in addition, while you are in services.msc disabling "Windows Search" you also need to disable "Storage Service", by using the exact same sequence of steps.

    Don't worry, despite its name it isn't a necessary service. At least I've not experienced any ill effects for disabling it.

    To verify that this is the culprit, you can do the following. Leave the service running, then start Sysinternals' Process Monitor utility. When the "Filters" dialog opens, add a filter with the following settings:

    "Path" "Contains" "system volume information"

    After you click OK, the main window shows. Pull down the "Filter" menu, and ensure "Drop Filtered Events" is checked.

    Then insert a USB flash drive.

    You should see some lines appearing in the main window. You'll see the path referring to S.V.I. on the USB drive. The ones you care about have a Process Name of svchost.exe.

    Note down the PID from the next column, and then start Sysinternals Process Explorer tool. Click on the PID column to sort by ascending PID, and then scroll down to find the entry with the value you noted just above.

    Hover over the name of the process and you'll see the service(s) run by this process. It should show "Storage Service."

    You have just found your smoking gun.

    • thanks for posting this. This solution was posted just yesterday on Microsoft Community by another user, whose name I haven't received permission to use here. I've tested it on my machine (Windows 10 Build 1709), and it seems to work just fine.
      – BillDOe
      Commented Nov 5, 2017 at 23:59
    • @BillOertell That might well have been me. :) If the tone of the message seemed somewhat critical of Microsoft, and the initials of the poster match the first two letters of my user name then it probably was. What is interesting is that the thread where I posted is no longer showing up in Google searches, at least I'm totally unable to find it.
      – dgnuff
      Commented Nov 6, 2017 at 21:06
    • I didn't really take a good look at your SE user ID. That was most definitely you. Thanks again.
      – BillDOe
      Commented Nov 7, 2017 at 20:37
    • Apparently turning off "Storage Service" disables the Microsoft Store app. With this off I was getting error code: 0x800706D9. The article here: answers.microsoft.com/en-us/windows/forum/… lists this service as one cause for the Microsoft Store app error. I was receiving this when I tried to install a couple of apps from the Store. Turning it back on fixed it. If you use this and then find MS Store apps not installing, turn it back on.
      – BillDOe
      Commented Nov 18, 2017 at 1:58
    • @BillOertell Ugh. Typical of Microsoft. It's a complete non-issue for me since I don't use the Microsoft Store at all, but I guess it means if you do need access to the store you're stuck. Regretfully, complaining to Microsoft about this is about as effective as trying to stop an Amtrak train by yelling at it. They are so fixated on the party line that S.V.I. is an essential folder and you can't live without it, that they simply can't grasp what's going on. Kinda like trying to explain color to a blind person. :(
      – dgnuff
      Commented Nov 28, 2017 at 18:22

    Although the following is not a clean solution, it could be a workaround in some cases.

    In my case  I didn't want anything to be written on the drive. The creation of the folder System Volume Information was causing me issues.

    Because none of the solutions seemed to work for Windows 10 v1703, what I did and seems to be working is this:

    1. Delete contents of System Volume Information folder
    2. Delete the folder itself
    3. Create a new file with name System Volume Information

    For #1 and #2 I used the command in elevated command prompt:

    del /S /Q "Q:\System Volume Information" && rmdir "Q:\System Volume Information"

    For #3 I used the command

    fsutil file createnew "Q:\System Volume Information" 0

    You need to replace Q: with your drive letter.

    Since we can't have a folder and a file with the same name, the System Volume Information folder can't be created.

    Note: My drive is FAT formatted. For NTFS formatted drives, I guess we need to first take ownership of the folder before deleting it.

    • May be that's also replaced by a blank symlink to nul with mklink command.
      – Biswapriyo
      Commented Sep 27, 2017 at 21:23
    • I'm using USB Flash drives to shuttle files between a Linux machine and a Windows 11 machine. To implement this solution I create the empty "System Volume Information" file with the USB drive mounted on the Linux system, using the "touch" command, and then assign read-only permissions with "chmod 444". Having to place the file on the drive beforehand is a minor annoyance compared to Windows indiscriminately "fixing" it.
      – Andrew P.
      Commented Feb 16, 2023 at 13:09
    • make the file hidden: fsutil file createnew "Q:\System Volume Information" 0 && attrib +s +h "Q:\System Volume Information"
      – AntonioK
      Commented Mar 1, 2023 at 13:05

    I had this problem on Windows 7. In my case the folder appeared only on one USB stick, so I was convinced the problem wasn't about indexing or restoration being configured wrongly for removable devices. I didn't attempt to perform the configuration changes suggested in other answers.

    The problem was fixed by deleting the folder. Of course the folder is protected (read only, system attribute and hidden), so the attributes need to be reset first.

    Open cmd.exe with administrator rights (instructions).

    Set the default volume to your USB drive (e: in my case). This removes the need to type full paths: C:\Windows\System32> e:

    Reset attributes on folder and content using attrib:
    E:>attrib -h -s -r "System Volume Information" /S /D

    (after this command the folder must be visible.)

    Delete directory:
    E:>rd "System Volume Information"

    Unplug the USB stick (after using "eject" if necessary). Now if you plug it again the folder won't reappear (unless removable media have been configured as indexed. In that case the other answers can be used).


    I believe I may have just solved 2 problems, which is that in many cases you need Windows Search running (so you can use the Windows Media Player Service) and also want to keep S.V.I. folders off removable drives:

    how to both enable Windows Search AND avoid System Volume Information folder being written to removable drives

    I'm a bit shocked I figured it out as fast as I did but involves 2 more GPEDIT settings in the same Search section as the first one. Please verify independently if you can.

    Added a day later...this is still working for me today.

    You must log in to answer this question.

    Not the answer you're looking for? Browse other questions tagged .