Does anyone know the solution to the dreaded black screen on Kali Linux when booting from VirtualBox? I imported the ova appliance straight from Kali's website (Kali-Linux-2016.2-vbox-i686.ova) and, set the video memory to 128MB, switched the USB 2.0 to USB 1.0 as instructed (to get it to boot at all). I've tried the "root"/"toor" combo as suggested by other posts, but nothing seems to work. It looks like it's running, however. Never had this problem with other versions of Linux to date. Any ideas?

  • Did you properly install the Grub boot loader?You have to click yes in the option which appears in the end of installing the kali VM - "Install the Grub boot loader to the Master boot record"
    – BoRRis
    Jul 22, 2018 at 12:46
  • 1
    I have the black screen problem with the latest Kali VirtualBox Image 2019.2 with Virtualbox 5. I updated to Virtualbox 6, and the problem is solved. Kali VirtualBox Image is usually made with the latest virtualbox, so it's a good idea to keep your Virtualbox up to date, if you encounter any problems.
    – Hieu
    Jun 29, 2019 at 9:22
  • I think your problem is in video memory. Go to Settings->Display and give it at least 32 MB
    – Dareten
    Mar 29, 2020 at 12:41

7 Answers 7


I just had this issue. It turned out, after trying a bunch of other stuff, that it was caused by the OS being set to Ubuntu 32 bit instead of 64 bit.

I turned back on the stuff I had turned off, like PEA/NX, 3d acceleration, etc. from the default. Seems to work fine now that it has the correct OS.

Worked for me, hope it helps someone. BTW - host system is Windows 10 Pro 64 bit.


I had a black screen running Kali in Virtualbox just after installing it and installing all the updates and was able to fix it by going into system settings in Virtualbox and just unchecking the Enable 3d acceleration box in the Display settings.


Kali Linux on Virtual Box - I think this is the same question. I just answered this guy too. I had the same problem. I had a black screen because kali was running, but I couldn't see it. So, click view at the top and select switch to scaled view. This should adjust the display so that kali recognizes it and shows you what you should be seeing.

  • That worked but screen not updating, just got stuck
    – Vicrobot
    Jul 26, 2019 at 12:32

I've been struggling with the black screen issue for a LONG time.

Here's how I was able to fix it the other day.

  • Launch virtualbox, go to help > about virtualbox

  • Take a look at your current version. If you're running a 5x version, then you have found your issue.

  • Remove virtualbox from your machine. If you're on linux, use the following commands(your vms shouldn't be deleted when doing this) sudo apt-get remove virtualbox; sudo apt-get purge virtualbox*;

  • Once you've uninstalled virtualbox, go and download the latest version from the website : https://www.virtualbox.org/wiki/Linux_Downloads Make sure that you get the one for your current version of linux. Find your current version with this command uname -a

  • After downloading the virtualbox deb package, install it with the following command(replace the file path with that of your specific deb package) :

    dpkg -i ~/Downloads/virtualbox-.1_6.1.18-142142~Ubuntu~bionic_amd64.deb

Once done, you should be able to launch virtualbox and run kali without issues. I figured out that this was the issue for me after learning that kali is developed and tested using the most recent versions of virtualbox and vmware.

Hope this resolves the issue for someone else too!

  • this one works for me. My version was 5 and now it works Aug 2, 2021 at 20:16

The problem is that the laptop VirtualBox is installed does not have hardware virtualization as an option (a low end dual core intel B960 CPU) which explains a lot. The solution is to tell Kali to not look for Xen at boot.

These instructions will solve this little problem. Press "e" at the boot menu, scroll to the line that starts with "linux" and remove "quiet" and add "noreplace-paravirt" to the line, hit ctrl-x and let it finish booting (may take a couple of minutes), then login. Open a terminal and edit the /etc/default/grub w/editor of your choice and change GRUB_CMDLINE_LINUX_DEFAULT="quiet" to "GRUB_CMDLINE_LINUX_DEFAULT="noreplace-paravirt" Run "update-grub" and reboot.

  • 1
    Note: the low end CPUs are so slow, it's better to just either boot from a USB or create a dualboot system, rather than using a VM.
    – DaveN
    Apr 17, 2017 at 19:18
  • 1
    In my Kali Linux version (2017.1) I scrolled to the line in the boot screen (for me it was Graphical Install), then hit the Tab key to edit the line, replacing "quiet" with "noreplace-paravirt". Then the install worked.
    – Graham
    Apr 30, 2017 at 13:48

I've installed Kali 2019 using having enabled EFI mode for the VM. Reinstalling without that option enabled did the trick.


Enable PEA/NX in settings -> system -> Processor

  • 2
    C'mon for real... Provide a whole lot more detail than just this like explaining what these options do perhaps or otherwise....You might need to be converted to a comment, feel free to flag a mod and ask for this to be done until you earn enough rep to write comments... this is an easy and simple task too by the way. May 11, 2017 at 21:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.