7

I installed the Creators Update (version 1703) on my Windows 10 Pro computer, but now I get updates for Microsoft Office when I try to update Windows. I checked the advanced settings and found the option "Give me updates for other Microsoft products" is unchecked and disabled. There is also text at the top that says "Some settings are hidden or managed by your organization."

How do I stop receiving updates for other Microsoft software and make that option "Give me updates for other Microsoft products" enabled ?

Edit: I really need to find a way to make this option enabled again.

Screenshot

  • 1
    Is this computer on a domain and/or is Group Policy being used? – InterLinked May 1 '17 at 10:36
  • 1
    none being used – Welliam May 1 '17 at 10:42
  • next time use my linked tool and change the source. it does everything you want – magicandre1981 May 1 '17 at 17:40
  • the tool sets the policy setting. But do what ever you want, I'm out here – magicandre1981 May 2 '17 at 15:47
  • Being on Windows Server 2016, the only thing that worked for me was to delete the "AU" sub key from "HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate" via RegEdit. Tip from here. I still needed to reboot and enter the "Advanced options" in the update panel several times, until the check box came up enabled. – Uwe Keim Dec 13 '18 at 7:30
9
+50

It looks like something potentially configured the Local Group Policy on that machine that affects Windows Updates. To double-check, open the Local Group Policy Editor by searching for gpedit.msc and choosing Run as administrator, then navigate to the following location:

Computer Configuration\Administrative Templates\Windows Components\Windows Update

On the right-hand side, double-click the policy to Configure Automatic Updates. If it is Not configured, it should look like this:

Configure Automatic Updates

If it is configured, you have the option to switch it to Not configured accordingly and that should allow you to regain control within the Settings interface.

On the other hand, if the Configure Automatic Updates is already set to Not configured, it's possible that something changed the associated registry keys that correspond to those Windows Update settings. To verify that, open the Registry Editor by searching for regedit and choosing Run as administrator, then navigate to the following location:

HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate\

In the screenshot below, the only value that appears on the right-hand side is there because I have configured my system to not install device drivers within Windows Update:

Windows Update Registry

If you see additional values on the right-hand side, something configured your system in that regard and may be causing the problem. You can potentially delete those DWORD values to restore functionality, but I would urge you to proceed with caution and export the HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate\ hierarchy to a .reg file first.

(Source: Group Policy Settings Reference for Windows)

  • yes setting Configure Automatic Updates to enabled helped me and the option is now enabled. registry is the same like you.... thanks – Welliam May 1 '17 at 15:12
  • Always glad to help! – Run5k May 1 '17 at 15:13
  • Be wary, the some settings are hidden or managed by your organization flag means that group policy restricted your settings, but it normally also means it was done at a company/enterprise level. The setting you just changed might get changed back by a central authority. (example: I handle am one of the GPO guys at my company, and if you made that change in local policy it'd be reset within a week here.) That's because the central authority wants you to get the uniformed settings and download the updates they send you, regardless of what you want. – Ruscal May 1 '17 at 17:58
  • @Ruscal, certainly good advice and I understand where you are coming from: at work, I manage the GPO architecture for three domains. However, I thought it was relatively safe to assume that this isn't a domain workstation because the OP emphasized that they installed the Windows 10 Creators Update themselves, and that it is a Windows 10 Pro machine. Yes, those can join an Active Directory domain, but Windows 10 Enterprise is much more common at the corporate level. Regardless, thanks for the feedback and hopefully the OP will chime in to help clarify the situation for us. – Run5k May 1 '17 at 19:16
4

Try this :

  • Go to Run, type gpedit.msc
  • Navigate to `Computer Configurations -> Administrative Templates -> Windows Components -> Windows Update
  • In the right hand window double-click Configure Automatic Updates, set it to Not configured and click Apply.
  • Go to Start -> Settings -> Update & security -> Windows Update, click on Check for updates. Once it finishes saying "Your device is up to date", click Advanced options.
  • Give me updates for other Microsoft products when I update Windows should now be available.

If this does not work, try running Control Panel / Troubleshooting, and under System and Security, click on "Fix problems with Windows Update" and follow the indications.

  • read my question again the option is disabled – Welliam May 1 '17 at 14:57
  • Sorry, the rewritten answer may be more to the point. – harrymc May 1 '17 at 15:14
  • Confirming this worked for me - thanks! – David Gardiner Jun 25 '17 at 13:08
2

You should use the 3rd party tool called Windows Update MiniTool which allows to select which updates can be installed and allows to block updates like you could in former Windows versions.

enter image description here

An alternative to the standard Windows Update What you can do:
• Check for updates
• Download updates
• Installing Updates
• Deleting installed updates
• Hiding unwanted updates
• Get direct links to the *.cab / *.Exe / *.Psf update files • View update history
• Configure Automatic Updates
• This tool is like the external powershell module PSWindowsUpdate, but much more advanced and user-friendly features
• The tool relies and use same WU infrastructure, all downloading are through WU it's not a downloader

Here you can change the checking mode to only notify about updates and download the updates manually when you want. You can also change the update service entry from Microsoft Update to Windows Update to only get Windows updates.

enter image description here

  • The WUMT link seems to be dead now (pointing to an empty blog). – Uwe Keim Dec 13 '18 at 6:52
  • @UweKeim I replaced it with a link to majorgeeks. There is also a similar tool which is also open source – magicandre1981 Dec 13 '18 at 15:45

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.