2

I am doing encrypted disk installation. First partition is /dev/sda1, mount point is /boot and it is unencrypted and second partition /dev/sda2, mount point / and it is encrypted partition. Whole installation went fine but stuck at Install the GRUB boot loader on a hard disk. It's not going anywhere from here. No movement in progress bar.

See image:

enter image description here

Update:

I have just tried to install without any disk encryption and it is stucked again on same step.

0

Try to do the installation without an internet connection. You can skip some steps that require internet by hitting the esc key and manually select the next step.

When everything is installed you only need to set the repository URL in the sources.list manually.

cd /etc/apt/source.list
gedit sources.list 

add the line at the top:

deb http://http.kali.org/kali kali-rolling main contrib non-free

and run the apt-get update, you know how it works.

| improve this answer | |
  • How I will boot into installed Kali without GRUB? Did you read the question? – Syed Salman Ali Apr 25 '17 at 21:41
  • So you are saying that the failed installation is not the problem? And that the actual problem is that you don't want to install grub at all? Am I right? – Rutger van Velzen Apr 26 '17 at 13:59
0

I hadthe same trouble while doing an install without internet.
That was solved by re-running the GRUB install step:

  1. press ctrl+alt+F2 or etc to switch to another blank terminal session, while in the stuck screen.
  2. kill some of the process later than update-grub, such as the osprob etc.
  3. switch back to graphical install, by pressing Ctrl+Alt+F5 on my pc, you found that the GRUB install failed and can go back.
  4. do install the grub again, that I successfully finished the step.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.