I have Windows 10 build 15063.138. How do I have Windows not combine buttons on taskbar? In Settings/Taskbar, the "combine buttons on other taskbars" option is gray out.


There is a registry setting that enables or disables this feature. You can use the Registry Editor (Start > Run > regedit) to edit the following keys:



By setting their value to "0", you will be able to select the grouping options in the taskbar properties.

  • Thank you for your quick reply. I tried regedit and found nothing under CurreentVerion\Policies (HKCU). It couldn't be expanded. Should I right click and add a new key?
    – yky
    Apr 17 '17 at 3:29
  • HKLM does have \Policies\Explorer but there is no NoTaskGrouping key. Should I add one?
    – yky
    Apr 17 '17 at 3:36
  • @yky - Yes. It should force whatever is disabling the dropdown menu to be overridden. If the second one doesn't work by itself, try creating the missing tree needed for the HKCU hive. Remember to restart your computer after each change so that it can be properly applied to explorer.exe.
    – 1234567
    Apr 17 '17 at 4:01
  • Should NoTaskGrouping be a DWORD?
    – yky
    Apr 17 '17 at 5:01
  • @yky - Yes, a DWORD with a value of 0 (decimal).
    – 1234567
    Apr 17 '17 at 13:31

It's different between "Grouping of Taskbar Buttons" & "Combining of Buttons".

To disable "Grouping of Taskbar Buttons", under the following key


set NoTaskGrouping DWORD to 1 (remove it to enable)

To disable "Combining of Buttons", under the following key


set MMTaskbarEnabled DWORD to 1 and MMTaskbarGlomLevel DWORD to 2 (remove them to enable and restarting Explorer task is required)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.