2

I have a Lenovo Thinkpad T550 with a trackpoint mouse in the middle of the keyboard.

It was working great, but then the keyboard became defective so I bought a replacement keyboard (Lenovo did not sell any so I bought from a non-official website that insists they sell only Lenovo-produced parts). After inserting the new keyboard, the keys work fine, but:

PROBLEM: The cursor always slowly moves to the lower left.
One pixel every few seconds.

It is troublesome because:

  • When selecting from a list (ex: Firefox URL autocomplete) with the keyboard arrows, the cursor moves and loses my selection
  • When watching a movie, the mouse movement unhides the GUI controls every few seconds

I have tried putting the red plastic thingy in all four positions, but the cursor always keep migrating to the lower left.

I have heard that UltraNav is supposed to perform calibration? I am on Linux (Ubuntu 2016.04.1) so I might not have it. My previous keyboard did not seem to need it though, and the OS has not changed.

QUESTION: How can I prevent the cursor from moving on its own?

  • I'm having the same issue; time, movement on it's own. It manifested after a system update. Try booting a live linux and see if it exists there. – petermolnar May 1 '17 at 19:29
1

I'd return the keyboard as defective.

The Lenovo trackpoints all re-calibrate themselves. You can test this yourself by holding it into any direction... in a few seconds, the cursor will stop moving. Now, release it and you'll see the cursor move in the opposite direction for a few seconds. They don't need software for this.

What I suspect is happening is that there is enough "noise" here from movement that this auto-calibration isn't totally rounding out the false movement.

In any case, what you bought is defective. Get a new one.

| improve this answer | |
0

I agree with Brad in that the best option would be to return it as it seems there are some irregularities in the hardware. However, if that is not an option for you, you can try different calibration profiles like the person at the end of this thread: https://forums.lenovo.com/t5/ThinkPad-T400-T500-and-newer-T/Trackpoint-Drifting-after-let-go/td-p/259473

I have been trying to test these profiles, but I'm not sure it will work on my Yoga 260 with the Elan ultranav driver. Try exploring your device's properties using xinput and see if you can find something that works.

| improve this answer | |
0

Since kernel 3.19, there's a drift_time parameter you can try changing. It defaults to 5 (times 107ms, c.f. https://github.com/torvalds/linux/blame/master/drivers/input/mouse/trackpoint.h#L77 ) which seems to be too high, as a steady hand can trigger calibration in an off-center position, but sensor noise will prevent recalibration and the trackpoint might get stuck in drifting condition.

So setting it to a lower value should fix the problem instantly.

echo 3|find /sys -name drift_time -exec tee {} \;

You could vary the value a bit if it either still gets stuck. 1 which was my first attempt stops the drift getting stuck, but causes recalibration to trigger too often while middle-mouse-button scrolling.

See https://github.com/torvalds/linux/blob/master/Documentation/ABI/testing/sysfs-devices-platform-trackpoint for the original patch author's opinion about the issue (that the value should be raised instead of decreased, which I have not tried).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.