I'm on Ubuntu 17.04. Trying to increase the open file limit, and none of the instructions I've found online are working. I can go up to 4096, but can't go past that.

$ ulimit -n
1024
$ ulimit -n 4096
$ ulimit -n
4096

That works. This doesn't:

$ ulimit -n 4097
bash: ulimit: open files: cannot modify limit: Operation not permitted

It appears to be because of the hard limit:

$ ulimit -Hn
4096

I've tried adding these lines to /etc/security/limits.conf:

*                hard    nofile          65535
*                soft    nofile          65535
root             soft    nofile          65535
root             hard    nofile          65535

Also added this line to /etc/pam.d/common-session and /etc/pam.d/common-session-noninteractive:

session required pam_limits.so

Since doing that, I've rebooted my computer. Changes to limits.conf don't seem to affect anything. The hard limit is still stuck at 4096, preventing me from going any higher. How do I increase my open files limit?


Here's some additional config info:

$ cat /proc/sys/fs/file-max 
1624668
up vote 33 down vote accepted

OK, I finally figured this out. The limits I was setting in /etc/security/limits.conf were being applied, but they were not being applied to the graphical login. This can be verified like this from a terminal window:

$ ulimit -n
4096
$ su mkasberg
Password:
$ ulimit -n
65535

More research led me to this bug report, which got me pointed in the right direction. In order to modify the limit that is used by the login shell, we need to add the following line to /etc/systemd/user.conf:

DefaultLimitNOFILE=65535

That change works, but only affects the soft limit. (Leaving us capped with a hard limit of 4096 still.) In order to affect the hard limit also, we must modify /etc/systemd/system.conf with the same change.

The changes I made in /etc/pam.d were not necessary. At least on Ubuntu, this is already working. Also, it was not necessary to change settings for root and * in limits.conf. Changing limits for mkasberg was sufficient, at least for my use case.


In Summary

If you want to increase the limit shown by ulimit -n, you should:

  • Modify /etc/systemd/user.conf and /etc/systemd/system.conf with the following line (this takes care of graphical login):

    DefaultLimitNOFILE=65535
    
  • Modify /etc/security/limits.conf with the following lines (this takes care of non-GUI login):

    mkasberg hard nofile 65535
    mkasberg soft nofile 65535
    
  • 1
    DefaultLimitNOFILE=65535 did the trick. But why /etc/security/limits.conf does'nt work? – Suvitruf Jan 4 at 7:44
  • 1
    The GUI login uses systemd, which apparently has it's own configuration (/etc/systemd/system.conf) that is independent of the normal configuration for terminal sessions (/etc/security/limits.conf). I don't know enough about systemd to know why it was implemented this way. – mkasberg Jan 4 at 17:22
  • Thank you! Hours of searching and trying everything, but this fixed the issue. – Roger Collins Mar 19 at 23:15
  • @Suvitruf because it's ignored in a systemd system. I'm posting an answer. – Marc.2377 May 12 at 21:54

No need to change anything in the /etc/security/limits.conf file, it is ignored if you are using systemd.

(reproducing a modified answer to another question on the network...)

An alternative for those who prefer not to edit the default /etc/systemd/system.conf and /etc/systemd/user/conf files:

  1. create a new file /etc/systemd/system.conf.d/limits.conf with these contents:

    [Manager]
    DefaultLimitNOFILE=65535
    
  2. run systemctl daemon-reexec as root

  3. logout and login again

  4. check your new limit with ulimit -n.

Refer to the systemd-system.conf manpage for details.

Using Ubuntu 17.04 I got the described hard limit:

user@paresh.com:~$ ulimit -Hn
4096

I could lower it using ulimit, but not increase it, just as the question describes it. ulimit manual describes:

only root can increase the hard limit.

So I tried to set a higher limit in /etc/security/limits.conf like this:

user hard nofile 9999

and a fresh login like ssh localhost -l user gave me the new limit:

user@paresh.com:~$ ulimit -Hn
9999

I hope this works for you too.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.