0

My setup includes ubuntu 16.04 and dual monitors. Nvidia drivers are installed for the proprietary graphics card Quadro K1200. When using Nomachine to remote control this desktop from a windows laptop having one screen 1920x1080, the two 1920x1080 screens of the dual-setup get squeezed into one and are shown as one screen of 3840x1080.

Now obviously when such a large screen of size 3840 is tried to fit in only 1920 pixels, display quality is very poor and screen is unreadable. But clearly Nomachine claims that it can detect multiple screens and allow user to view one screen at a time. Even Nvidia x-server settings on ubuntu say that screen resolution is 3840x1080.

So is it possible that nvidia is merging the two screens into one and that is why Nomachine is not able to detect 2 screens? Is there any other software recommendation that can be made that will work out of box in such scenario?

EDIT:-

I installed several other desktop environments in Ubuntu unity like lxde, xfce, lubuntu, xubuntu, mate, enlightenment, plasma. Upon doing this, afterwards i turned off my dual monitors and tried remote viewing the ubuntu desktop from a windows laptop and voila!, the contents on the 2 screens were squeezed to one screen of 1920x1080 and there is no quality loss. This is because now Nomachine thinks my ubuntu desktop is single monitor of 1920x1080 and it has to broadcast it to my windows laptop which is also a single screen of 1920x1080. Things work out perfectly.

Everything is readable now with the 'Fit to Windows' Options selected. Earlier with this option selected for my 1920x1080 laptop, contents were rendered unreadable because as i was telling you that Nomachine was for some reason trying to capture the 3840x1080 screen onto my laptop's screen. So everything got squeezed and zero readability. When i unchecked Fit to Windows, readability was perfect but to move from one region of screen to another i had to use scroll bars which was annoying. The entire screen should be visible at once on my laptop.

Teamviewer handles this by creating separate screens for each monitor and allows switching between multiple displays and that worked. I don't know why it did not wokr earlier for Nomachine and now after installing different DEs, it works now. But it only works in the sense that now Nomachine reads my ubuntu server as a single 1920x1080 screen, not 2 screens of 1920x1080, so it combines the contents of the two screens on ubuntu computer to one screen while remote viewed using Nomachine from windows laptop. Maybe some dependency package installed during installation of DEs helped me out.

0

There are two possibilities here. The first is to make sure that you have uselected the correct icon in the short-cuts at the bottom of the menu. For example, what happens if you use Ctrl-Alt-I? This is used to identify the monitors whereas Ctrl-Alt-A is used to switch to viewing all monitors in one window. You can also do it via the menu once you are in the session. Go to the Display settings (Ctrl-Alt-0 -> Display). The NoMachine website Documents and tutorials section has all the images which illustrate what I mean, see their switching-the-view-between-multi-monitors-during-a-remote-desktop-session tutorial and the Menu guides.

Failing that you should check the output of xrandr -q

  • This issue got corrected recently. See EDIT above for details. in nutshell my new question is how the problem resolved itself automatically. – user_1_1_1 Apr 26 '17 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.