0

My laptop's optical drive did not prompt up anything when inserting blank CD-R

When I click my optical drive, this message shown:

windows cannot read the disc

So, it means optical drive detected the blank CD.

Normally this will show up like this one right?

Windows Disc Info window

But nothing show up for me.

However, my laptop's optical drive can read formatted disc.

This is my partition for optical drive, is it normal? Or something else wrong?

Disk management

Any help would be appreciated.

  • Last time (about 4 months ago) I recall the box will prompt up.
  • I checked my driver for optical drive is up to date
  • I tried to uninstall the driver and restart computer, not working.
  • Which version of windows? – Stese Apr 19 '17 at 10:28
  • My laptop's windows version is Windows 10 – Chek Wei Tan Apr 19 '17 at 10:29
1

To solve the Autoplay issue check this setting :-

Autoplay Options Settings >>> Devices >>> Autoplay

Make sure Autoplay is 'On' and that the Removable Drive option is set to 'Ask every time'

After checking that, and it still not behaving, try another blank CD-R. Also check that the drive you are using supports the type of disk. Ie, it's not a DVD you are using.


The error you've given states that the machine couldn't read the disc, not that it was specifically blank, which might be causing confusion. Check that the data side of the disc is clean, with no scratches.

Also check that the CD hasn't been used before. You can often see this by looking at the surface of the disc and noting if there is a colour change. See the image for an example.

CD with recorded data

  • My optical drive model name is Slimtype DVD A DA8A6SH. – Chek Wei Tan Apr 19 '17 at 10:37
  • Sorry, I done everything you said but still not working. – Chek Wei Tan Apr 19 '17 at 10:39
  • Do the settings match the above? Autoplay is turned on? – Stese Apr 19 '17 at 10:39
  • Ya Autoplay is on and Removable Drive option set to 'Ask every time' – Chek Wei Tan Apr 19 '17 at 10:41
  • Try another known blank CD-R. – Stese Apr 19 '17 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.