I am having an issue with my Macbook Air, it cannot be pinged. I tried to ping it's IP from another computer, and the connection timed out. However, the Macbook Air can ping that computer. Although typing ping from the Macbook Air also results in timeouts.

Some things to note: - Macbook Air Mid 2011, OS X El Capital 10.11.6 with Bootcamp - Firewall is completely turned off - Remote Login is turned on - Stealth Mode is turned off - /etc/hosts is properly encoded (ASCII English Text) - I do not have Little Snitch or any antivirus software running. - Trying to telnet localhost results in connection refused - I tried all options on both my work network, as well as home network, with the same results on both networks.

I'm really at a loss at this point, any help would be appreciated.

  • check if loopback interface is up, then check if the loopback has the proper ip/mask. firewall and REALLY weird routing tables could cause this too. (I'm no mac expert)
    – behrooz
    Commented Apr 20, 2017 at 2:55
  • @behrooz How can I check that? I too am no mac expert, haha.
    – sme
    Commented Apr 20, 2017 at 3:20
  • @behrooz I ran ifconfig, and the loopback interface seems to be up. lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16834
    – sme
    Commented Apr 20, 2017 at 3:31
  • Update: I restarted the MacBook in safe mode, and I am able to ping localhost now. Does this imply there is some sort of startup software that is preventing incoming requests?
    – sme
    Commented Apr 20, 2017 at 3:51
  • Update 2: I there was a folder in /Library/StartupItems, called cma, and looking at the files within it, it seemed to be related to MacAfee. I deleted that folder, restarted in Normal Mode (instead of safe mode), but I still can't ping localhost. I can only ping in safe mode... very strange
    – sme
    Commented Apr 20, 2017 at 4:03

1 Answer 1


Finally found out the problem, it was McAfee. I navigated to /Library/McAfee/uninstall.sh, typed sudo ./uninstall.sh. After it was uninstalled, I restarted and I can ping myself now, as well as ping the mac from other computers.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .