4

I have a Dell laptop with a Killer Wireless AC 1535 card in it. Sometimes I'm experiencing extremely slow connections (Kbits instead of Mbits) when connecting to my Linksys router at home. This mostly goes for normal browsing or downloading over FTP.

The weird thing is, my other devices (mostly Apple: iPhone 6, Macbook Pro, Samsung TV, etc) have no connection issues whatsoever. If I tether to my iPhone, I have no problems. At my office, I have no problems.

Also, if I run a speedcheck with the accredited Swedish tool called www.bredbandskollen.se everything looks normal and I get full speed according to my ISP connection spec. I haven't looked into exactly how they measure though.

Only the Dell has problems at home.

Things I've tried:
- Disable all type of "traffic shaping and QoS services" in the Killer Wireless Suite application.
- Reset network settings on Dell.
- Disabling Bluetooth and other radios on Dell.
- Change channels on router.
- Change Wifi mode on router (A/AC/B/G/N etc.)
- Disabling 2.4 or 5 GHz

Detailed hardware involved:
- Dell 15" "New" XPS 9560, Windows 10
- Killer Wireless AC 1535, driver version 1.1.67.1760
- Linksys E4200, firmware version 2.1.41.1623.51

When Googling around, it seems I'm not alone. But the issue still remains...

How do I go about to troubleshoot this "in-depth"? I have no problem diving deep into the rabbit hole, but I'm unsure of how to approach this problem and diagnose it.

Update 1
Here is a interesting output from the iPerf tests. UDP seems to work well, TCP not so well..

TCP run

iperf3.exe -c speedtest.serverius.net -p 5002
Connecting to host speedtest.serverius.net, port 5002
[ 4] local 192.168.1.121 port 56033 connected to 178.21.16.76 port 5002
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-1.00 sec 256 KBytes 2.10 Mbits/sec
[ 4] 1.00-2.00 sec 0.00 Bytes 0.00 bits/sec
[ 4] 2.00-3.00 sec 128 KBytes 1.05 Mbits/sec
[ 4] 3.00-4.00 sec 0.00 Bytes 0.00 bits/sec
[ 4] 4.00-5.00 sec 0.00 Bytes 0.00 bits/sec
[ 4] 5.00-6.00 sec 0.00 Bytes 0.00 bits/sec
[ 4] 6.00-7.00 sec 128 KBytes 1.05 Mbits/sec
[ 4] 7.00-8.00 sec 128 KBytes 1.05 Mbits/sec
[ 4] 8.00-9.00 sec 0.00 Bytes 0.00 bits/sec
[ 4] 9.00-10.00 sec 0.00 Bytes 0.00 bits/sec

[ ID] Interval Transfer Bandwidth
[ 4] 0.00-10.00 sec 640 KBytes 524 Kbits/sec sender
[ 4] 0.00-10.00 sec 446 KBytes 366 Kbits/sec receiver

iperf Done.

UDP run

iperf3.exe -c speedtest.serverius.net -p 5002 -u -b 100m
Connecting to host speedtest.serverius.net, port 5002
[ 4] local 192.168.1.121 port 56372 connected to 178.21.16.76 port 5002
[ ID] Interval Transfer Bandwidth Total Datagrams
[ 4] 0.00-1.00 sec 11.6 MBytes 96.9 Mbits/sec 1481
[ 4] 1.00-2.00 sec 12.2 MBytes 103 Mbits/sec 1562
[ 4] 2.00-3.00 sec 11.9 MBytes 99.4 Mbits/sec 1517
[ 4] 3.00-4.00 sec 11.7 MBytes 97.9 Mbits/sec 1494
[ 4] 4.00-5.00 sec 11.5 MBytes 96.3 Mbits/sec 1475
[ 4] 5.00-6.00 sec 11.9 MBytes 100 Mbits/sec 1523
[ 4] 6.00-7.00 sec 11.8 MBytes 99.1 Mbits/sec 1508
[ 4] 7.00-8.00 sec 11.8 MBytes 98.8 Mbits/sec 1508
[ 4] 8.00-9.00 sec 12.5 MBytes 105 Mbits/sec 1602
[ 4] 9.00-10.00 sec 11.2 MBytes 94.1 Mbits/sec 1440

[ ID] Interval Transfer Bandwidth Jitter Lost/Total
Datagrams [ 4] 0.00-10.00 sec 118 MBytes 99.0 Mbits/sec 8.086 ms 14212/14847 (96%)
[ 4] Sent 14847 datagrams

iperf Done.

TCP run with a different server

iperf3.exe -c iperf.volia.net
Connecting to host iperf.volia.net, port 5201
[ 4] local 192.168.1.121 port 56076 connected to 82.144.193.18 port 5201
[ ID] Interval Transfer Bandwidth
[ 4] 0.00-1.00 sec 256 KBytes 2.10 Mbits/sec
[ 4] 1.00-2.00 sec 128 KBytes 1.05 Mbits/sec
[ 4] 2.00-3.00 sec 0.00 Bytes 0.00 bits/sec
[ 4] 3.00-4.00 sec 128 KBytes 1.05 Mbits/sec
[ 4] 4.00-5.00 sec 0.00 Bytes 0.00 bits/sec
[ 4] 5.00-6.00 sec 128 KBytes 1.05 Mbits/sec
[ 4] 6.00-7.00 sec 128 KBytes 1.05 Mbits/sec
[ 4] 7.00-8.00 sec 128 KBytes 1.05 Mbits/sec
[ 4] 8.00-9.00 sec 128 KBytes 1.05 Mbits/sec
[ 4] 9.00-10.00 sec 0.00 Bytes 0.00 bits/sec

[ ID] Interval Transfer Bandwidth
[ 4] 0.00-10.00 sec 1.00 MBytes 839 Kbits/sec sender
[ 4] 0.00-10.00 sec 1.00 MBytes 839 Kbits/sec receiver

iperf Done.

Update 2
Another interesting fact. I disconnected/reconnected a 1 generation iPad Mini (Wifi-only) from my network. Guess what? Now the network speed is back to normal on my Dell laptop. Maybe I'm chasing ghosts, but I'll try and keep that iPad disconnected when not in use...

Update 3
This is still an ongoing problem, and it's still only a TCP problem while UDP works perfectly according to iPerf tests.
I have now also tried to rollback the drivers to the "inbox drivers" (default MS drivers) without luck. Sometimes when the issue occurs, I try to reboot and/or reset my network setting, but this doesn't help either. My last resort to be able to use the computer for work is to use tethering with my iPhone, then the network speed is back to normal.
I have an open support ticket with Killer without any activity for a week, which is disappointing.

| improve this question | | | | |
  • What about your wireless NIC's drivers? Have you checked whether you're on the latest? – happy_soil Apr 20 '17 at 8:21
  • Hi, yes. There's one update as of April 7th 2017 which I haven't installed yet. However, the release notes suggest that the changes from previous version stated in the question are unrelated to this. killernetworking.com/… But I'll give it a try anyway. – Anton Apr 20 '17 at 8:30
  • 1
    It might be worth looking into updating it regardless. Would also be interested to know the current performance using iperf, and have some before-and-after comparison following the driver update. – happy_soil Apr 20 '17 at 9:38
  • @happy_soil certainly, I'll run some pre/post iPerf tests tonight. Any test in particular you want me to run? I'll run standard TCP/UDP otherwise. – Anton Apr 20 '17 at 10:20
  • Yeah standard tests would do. I personally set the time to a minute as opposed to the default (10 s IIRC). – happy_soil Apr 20 '17 at 11:37
4

I was having trouble with the AC-1535 in my (not quite so) new Dell XPS 15 and got a couple of answers from Killer support.

I sent them a Killer diagnostics report and he said the signal strength was low enough that it might be causing problems, and suggested I try the following steps to fix it:

Right click Start

  • Right click Start
  • Click “Power Options”
  • Click “Change Plan Options” on currently selected power plan
  • Click “Change Advanced Power Settings”
  • Click “Wireless Adapter Settings”
  • Under “Power Saving Mode” change “Setting” to “Maximum Performance” on both “On battery” and “Plugged in”.

Sure enough this has boosted my signal strength by >10% when on battery, and average packet loss has gone from >10% to <1%!

Just found this: https://superuser.com/a/311452/167358 - which is basically the same answer. Wish I'd clicked on the 'related questions' button before!

| improve this answer | | | | |
  • 1
    It's been a while now and I can definitely confirm that my issues are resolved. Thanks a bunch, it was driving me crazy. I don't understand why this issue hasn't been solved on their side.(Killer/Microsoft). – Anton May 30 '17 at 20:59
  • @Anton are there situations where you'd want lower signal in your WiFi card in exchange for longer battery life? I suppose. But to make this the default seems like madness, I agree. – Ian Grainger Jun 1 '17 at 8:15
  • 1
    This may be the only fix for the issue. Installing Killer wifi drivers caused my laptop to get blue screen of deaths every few hours, so had to uninstall it. Just setting power mode to max performance fixed it though – Kshitiz Sharma Jan 3 '18 at 22:23
0

My problem was solved by Disabling the SmartByte Network Service from System Configuration ->Services tab and restarting.

| improve this answer | | | | |
0

My router's 2.4Ghz wireless channel is configured to use a 40Mhz width. Even though I am connected to the 5Ghz endpoint (not using 2.4Ghz at all), making the following change reduced my packet loss rate and latency substantially (30% packet loss to under 0.01%).

  1. Open "Device Manager"
  2. Network adapters
  3. "Dell Wireless 1820A 802.11ac"
  4. Right click and select "Properties"
  5. Advanced
  6. 2G Bandwidth Capability
  7. Change the setting from "2.4G: 20Mhz" to "2.4G: 20/40Mhz"
| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.