0

The title is a bit unclear, but I've been playing around with keyboard shortcuts trying to find a way to launch a PowerShell script with a keyboard shortcut. I created the script, made a shortcut to said script, and then added a keyboard shortcut to that script shortcut. After some trial and error I finally made it work so I removed all the non-functioning versions of the script and their shortcuts.

The problem I have now is that Ctrl + Alt + 2 starts a PowerShell instance even though I've removed the original shortcut with that specific shortcut key command (or so I believe). This makes it impossible to write an @ sign because it instead opens a PowerShell instance when using AltGr + 2. I have tried creating a separate shortcut for a separate program and using Ctrl + Alt + 2 for that one in the hopes of overwriting the opening of PowerShell instance but to no avail.

Is there any way to find out which user-defined shortcuts I have in my operating system? Or at least, find some form of list of all the used shortcuts within the OS (Windows 10) and then edit them from there? I know this is possible on an in-application level (like editing shortcuts within Word or Excel for example) but I would need something similar on a global level.

A way to reset global hotkeys could also work, but that would reset other hotkeys that have been assigned. If this is the only way then I'll bite the bullet on this one but hopefully there's a way to only override a specific shortcut.

  • 1
    Post your edit 2 as an answer, and you can eventually accept it too – djsmiley2kStaysInside Apr 20 '17 at 14:36
  • Good idea :) This is not 'verified on an MSDN level' type of certainty though, but it is what worked for me. Not sure if those answers are too appreciated but I'll give it a go :) Thanks! – MagneTism Apr 20 '17 at 14:50
  • You can enumerate shortcut files with hotkeys – LotPings Apr 20 '17 at 16:47
3

So, I found the answer myself when looking around a bit further. Even though I removed the actual shortcut containing the shortcut key command this was not registered in the operating system. Only after restarting the computer did the change actually get registered. Hopefully this helps others in similar situations.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.