0

I've created a 200+ page Computer science project write-up, with a lot of code.

Recently, word started refusing to spell/grammar check the document, due to the amount of unrecognised text.

What can I do? I looked through a few paragraphs and saw that I had been making errors without even noticing. How can I force word to check the contents?

I have 12GB of RAM, is that not enough!?

How can I exclude the font of the code, it's all consolas/lucida console.

Would I have to manually go through each code paragraph and mark it as "do not check?"

3

I'd edit the style of your code paragraphs, changing the language (look for the Format button in the bottom left of the Modify Style dialog) so it's either marked as Do not check spelling or grammar or else as a language that you don't have the spellchecker for (i.e. one with no checkmark in the list).

If you're not using styles, I would suggest you should be. You should be able to create one, then apply it using Find and Replace, by find the fonts in question (probably one at a time) and replacing with the style you've created.

Possible caveat: IIRR, styling your code removes syntax highlighting.


Edit: if you don't want to get into styles, Find and Replace might do what you need: find by font (Find tab → Format button → Font... item → choose Consolas); replace with new language settings (Replace tab → Format button → Language... item → either check Do not check spelling or grammar, or choose a language without an ABC checkmark). Repeat for Lucida Console.

  • I'm done for... – Tobi Apr 21 '17 at 3:07
  • I'm literally going to copy the last few pages into a new document, and work from there. – Tobi Apr 21 '17 at 3:08

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.