2

For some reason I cannot see the network icon in the taskbar any more. When I go to "Turn system icons on or off" the network and action centre icons are off and grayed out so I cannot enable them.

I spent hours looking for a solution in the web, but none helped me. I checked the "Start menu and taskbar" group policy as suggested - everything is "not configured". I tried to delete "iconstreams" and "PastIconStream" registry values suggested by others but nothing helped, even after reboots.

The computer is joined to domain and I'm logged on as a domain user which is also a local administrator. I tried to switch to a local user, and also left the domain and defined workgroup - same issue. What can I do?

Edit: HideSCANetwork registry value does not exist, and "Remove the networking icon" group policy setting does not exist either (I also checked with gpresult /h gpresults.html as suggested below)

  • 2
    This is probably configured by a Group Policy for your domain. Speak to your IT admins. – DavidPostill Apr 21 '17 at 10:06
2

I had this problem for a while. Gave up on fixing it after trying many of the suggested methods like resetting the Icon cache etc.

I had it resolved after applying the fix for another problem: Can't open calendar on taskbar [Win7] i.e. I had the PreferExternalManifest registry tweak on and that was the source of both problems.

Just ensure that the HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\SideBySide\PreferExternalManifest is set to 0 and if you had to change it - reboot.

  • This worked. Most likely some drivers did that, but removing the drivers didn't fix the option back. – Denis V Jun 22 at 11:23
1

The networking icon is hidden if the the following Group Policy setting has been enabled:

User Policies/Administrative Templates/Start Menu and Taskbar/Remove the networking icon

This GP setting in turn sets the data of registry value HideSCANetwork to 1. This value is located at:

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

If the domain to which your computer is joined indeed has set this Group Policy setting, then your best course of action is to talk with your IT department. However, if the setting has not been enabled through Group Policy, you can simply delete the HideSCANetwork value from the Registry, then log out and back into your computer for the change to take effect.


I checked the "Start menu and taskbar" group policy as suggested - everything is "not configured".

I assume you looked at your computer's Local Group Policy by running gpedit.msc or searching for Edit group policy from the Start Menu. In this case, you're only looking at Group Policy settings defined on your local computer. In a domain environment, Group Policy settings can be defined at the domain level. Not only do these settings override those defined (or not defined) in your local GP, but the settings aren't visible in your local Group Policy editor.

Instead, run the following command to create a report of the Group Policy settings currently in effect on your computer:

gpresult /h gpresults.html

Then search the report for the text "Remove the networking icon" to see if this policy has been configured for your machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.