2

I am using a french keyboard on Windows 10, and as someone that regularly formats code in markdown (using backticks, like on SE), I am trying to find a way to disable the "smart" accents feature, or whatever the name of the following feature is.

If I press Ctrl + Alt + 7 (key combination for backtick, as you can see here), the backtick will not be written yet; I have to press any key again so that it does get written (I currently press space). The purpose of this feature is to be able to apply accents to any letter, for example if press Ctrl + Alt + 7 and then u then I will get ù. I'm guessing this is useful for many people, but the french keyboard already has keys for the most useful accented letters and this behavior is very annoying.

Is there any way I could disable it, so that when I press Ctrl + Alt + 7 the backtick gets immediately written ?

1

Found a solution: this allows to produce a

`

with just one keystroke of ², using Autohotkey:

+²::
Send ²
Return

$²::
Send ``
Send {space}
Return

To get ², just press SHIFT+²

  • Thanks ! so I guess the trick was to use Send ``.. simple but solves it ! – TrakJohnson Nov 14 '17 at 16:30
0

Use AutoHotkey. The following command would send a backtick when you press Ctrl-Alt-7.

^!7::`
  • 1
    Thanks for the advice, however I when I tried this I was surprised to discover that .. the behavior persists. Even if I remap it to another key combination, or try using Send or SendRaw, the same problem arises. – TrakJohnson Apr 21 '17 at 16:14
  • @TrakJohnson me too... – Basj Nov 13 '17 at 22:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.