0

Windows 7 | Acer Aspire Timeline 5820TD | Samsung mSata 128 GB | HDD Caddy

Acer 5820T

I have an older Acer 5820T laptop that I decided to try to boost the performance on. I also had an unused Samsung mSATA 128 GB SSD laying around that I would like to install into it and later put the operative system on.

Image: Samsung mSatamSATA

The Acer 5820T does not natively have a port where I can connect an msata ssd but it does have an optical drive that I am not using. I found out that it is possible to put a (normal SATA) SSD in a "HDD caddy" and use the optical drive slot to connect a second drive on most laptops.

Image: HDD Caddy HDD Caddy

I also found an adaptor for msata to sata.

Image: mSata to SATA adaptormSata to SATA adaptor

So I put the msata in the adaptor case, put the case in the hdd caddy and inserted it into the optical drive slot in the laptop.

Now the problem is that BIOS does not seem to recognize the msata at all.

I see "Boot priority order" as

  1. IDE1 :
  2. IDE0 : WDC WD74843726548364retc.

So it looks like it thinks the slot is empty.

I tried to run the Samsung magician program to see if it would find the drive but it did not find it.

I tried to remove it and put it back and also checked and doublechecked that it was properly connected.

Do I need to install drivers or is it the double adapter that messes it up, or any other idea on how to get it to work? Happy for help!

Update:

Bought (as recommended below) a Sata to USB cable. I just connected the Adapter with the mSata inside and it works. When I connected it, it downloaded and installed the drivers automatically. So the mSata works and the mSata to Sata adapter works.

mSata inside adapter connected via USB

Update 2:

Formatted the drive while it was connected with the cable (it had an old Windows install) and put it back into the HDD caddy and inserted the HDD caddy into the optical drive slot, and now it works :)

enter image description here

So in the near future I can install the OS and have a faster comp.

enter image description here

Awesome!

  • I assume you have verified that your device even supports booting from a device in that slot? – Ramhound Apr 21 '17 at 17:27
  • Yes, I have booted from a DVD or CD on the originally installed DVDrom in the past. So it supports booting from the slot. – Don King Apr 21 '17 at 17:32
  • 1
    Have you tried, to verify if the first adaptor works, by using it with a SATA to USB? This isn't a driver problem if your firmware doesn't even see it. – Ramhound Apr 21 '17 at 17:35
  • 1
    Verify if the first adapter is the problem by using a SATA to USB adapter. If that works, then you can rule out the adapter itself, which would leave the caddy as the culprit. – Ramhound Apr 21 '17 at 17:58
  • 2
    The SSD could be the problem. It's also possible the laptop's BIOS supports only SSDs the manufacturer offers. (You can try upgrading to the latest BIOS if you haven't already.) – David Schwartz Apr 21 '17 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.