1

Every time I try installing a program that needs elevated permissions in order to do so I'm always prompted to put my admin username and password in. This gets quite annoying when installing or tweaking a setting at my work.

I had it configured to just click "yes or no" when running something that needed elevated permissions and once I clicked "yes" it would just continue as my administrator account - but I forgot how to do it and now I am running Windows 10.

Note that I don't want to just right-click on an app and select "run as administrator". I need something that's permanent for anything I run that needs that.

If someone know how to go about doing this then please let me know!

  • You should disable UAC through the group policy if you want to be able to do that. – Ramhound Apr 21 '17 at 18:28
  • 3
  • Related How to fully stop UAC Windows 8 – Ramhound Apr 21 '17 at 18:40
  • Clarification: Are you trying to switch the UAC prompt from username/password to the Yes/No prompt? – Steven Apr 21 '17 at 18:41
  • I should point out, that if an installer is requesting for elevated permissions, that normally indicates your user doesn't already have it. In my experience very applications and/or installers actually need to be ran as an Administrator, and specifically for an installer, that's normalyl only done so the applicaton can be ran by multiple users. – Ramhound Apr 21 '17 at 18:44
3

As I understand your question, UAC now prompts you for a username and password, and you would prefer to see a "Yes/No" UAC prompt instead.

Normally if you are not logged in as a local Administrator, the UAC prompt you for credentials. Otherwise, you will get the standard Yes/No (Admin Approval) UAC prompt.

This behavior can be changed in the Local Security Policy.

  • Open the Local Group Policy Editor gpedit.msc (as an Administrator).
  • Navigate to the following: Computer Configuration, Windows Settings, Security Settings, Local Policies, Security Options
  • Check the policies starting User Account Control, specifically
    • Run all administrators in Admin Approval Mode: Enabled
    • Behavior of the elevation prompt for administrators in Admin Approval Mode: Prompt for consent for non-Windows binaries
  • That seems to have already been enabled. – StealthRT Apr 21 '17 at 19:46
  • Are you logged in as a user in Administrators? If so, are you using the same credentials to log in as you are to install applications? – Steven Apr 21 '17 at 19:47
1

A quick and dirty way is to run Explorer.exe as admin, after applying my tweak, run the several software tools and exit the Explorer, running as admin.

Here you need to allow the UAC prompt only once!

1

Alright this is what I had to do in order to get this to work.

I have 2 windows accounts.

-Normal account (non-admin)

-Admin account

I had to log into my Admin account and do the following:

  • Win + R > type in lusrmgr.msc enter image description here
  • Local Users and Groups box pops up enter image description here

  • Under Local Users and Groups (Local) choose Groups then double-click (or right click and select Properties) on Administrators. enter image description here

  • The Administrators Properties box comes up and you need to click on the ADD... button.

  • Doing so shows the Select Users, Computers, Service Accounts, or Groups box. Type in your NON-ADMIN windows account name and click Check Names button. It should then format your name as it looks in Active Directory. enter image description here

  • After the above is done, click the OK button and OK button again and log off your Admin windows account.

  • Log into your Normal windows account.

  • You now should be presented with the Yes/No dialog box when something needs Administrator rights to run/install/change or set to "Run As Administrator". enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.