7

With the update of Chrome v58, a lot of our internal sites are now appearing as insecure due to the local certs and self signed certs we're using. I put the workaround in for our Windows machines using GPO and enabling the key EnableCommonNameFallbackForLocalAnchors in the registry.

I cannot, for the life of me, figure out how to enable a local policy for Chrome on a Mac. I found the file that I believe I need to edit called /Applications/Google Chrome.app/Contents/Resources/com.google.Chrome.manifest/Contents/Resources/com.google.chrome.manifest. In that file I found the policy I just can't figure out how to turn it on.

Once I figure it out I can push out the change to my company with our Mac management software (Jamf)

Can anyone help?

11

Just type this into a Terminal

defaults write com.google.Chrome EnableCommonNameFallbackForLocalAnchors -bool true
4
  • 1
    Thank you so much. I've tried editing so many random files and couldn't find the magic incantation here. Super helpful! – Cody A. Ray May 18 '17 at 14:25
  • What's the -bool true for – Pacerier Sep 10 '17 at 0:11
  • it means set the value to true. not String type "true" but boolean type true – Kerem Baydoğan Sep 10 '17 at 15:35
  • I had to restart Chrome to make this take effect defaults write com.google.Chrome HSTSPolicyBypassList -string "localhost" – ow3n Feb 6 at 14:39
2

I think we figured it out.

We needed to create a file called "com.google.Chrome.plist" in /Library/Managed Preferences

That file contains:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple/DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>EnableCommonNameFallbackForLocalAnchors</key>
    <true/>
</dict>
</plist>

This worked and we pushed it out using Jamf. That said, if someone has a better way to do this please let me know.

Hope this helps someone.

1
  • 1
    Are you sure it's Managed Preferences and not Preferences? – Pacerier Sep 10 '17 at 0:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.