3

I am fiddling with Windows 10 new command prompt. I am with code page 936 (GBK).

I say "new" because I see in the Properties of cmd that there's a check to run legacy command prompt (need restart), by default unchecked, so I guess this one I am using is "newer".

The question is, searching the web only gives me some ways to add a font in registry to make legacy cmd to recognise it and show in "Properties"/"Default values" settings, like this:

http://www.techrepublic.com/blog/windows-and-office/quick-tip-add-fonts-to-the-command-prompt/

It mentions to add a font entry to the shown location in:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Console\TrueTypeFont

to make Windows aware of this font. I note that the fonts already listed there are the same ones that I can see in legacy cmd. In normal cmd I see more fonts.

enter image description here

Note that in the picture I opened a legacy cmd prompt, with some Terminal fonts, and in the Properties setting dialog, the fonts from which I can choose are Consolas and Lucida Console, same as in the registry.

And, if I switch to normal cmd, there are two cases:

  1. If I choose to edit "Properties", I see less fonts and the change works.
  2. If I choose to edit "Default values", I see more fonts but the change does not take effect.

In Properties:

enter image description here

I can choose between Yahei Consolas Hybrid and other fonts here, and cmd respects my settings and change the font immediately.

In Default values:

enter image description here

You can see more monospaced fonts here, like Dejavu Sans Mono, Monaco and so on, but you cannot make cmd change to these fonts.

I don't know the difference here, but it just doesn't make sense. Some settings that cannot be respected should not exist, not to mention the confusion caused: "Properties" and "Default values" are identical.

What I want, is to change the font in normal cmd to be Monaco, or Dejavu Sans Mono. If not possible, in legacy cmd.

And by the way, if someone can clarify the difference between "Properties" and "Default values", it would be great.

  • 1
    Normally (under Windows 7, for example) "Properties" applies to the current cmd window (and the shortcut which starts it) and "Default" applies to all cmd windows (however they are started). I've no idea if this still applies to Windows 10 "legacy" and "new" cmd windows... – DavidPostill Apr 21 '17 at 21:50
  • @DavidPostill It does and to change the defaults you have to explicitly chnage them – Ramhound Apr 21 '17 at 22:10
  • @DavidPostill Yes, In Windows 10 properties is still for the current window, default is for all future ones. Not sure about legacy. – Xalorous Apr 21 '17 at 22:13
  • Also, technet.microsoft.com/en-us/library/mt427362.aspx Here's all the info about the new console host. – Xalorous Apr 21 '17 at 22:14
  • Thanks for all the replies! I think you are right. What I see now is that in "Properties" I can see limited fonts and the change works, but in Default I see more fonts but it does not apply to this cmd, neither to another new cmd. Any thoughts? I doubt this has something to do with code page because: Yahei Consolas Hybrid is a font that can show both Chinese characters and English characters in monospace style, so it must include some Chinese fonts. My code page is GBK, and system detects that Monaco/Dejavu has none Chinese fonts, so it doesn't bother to show them in Properties fonts(?) – WesternGun Apr 22 '17 at 21:13
2

Now I find the answer, thanks all for helping. I will not accept my own answer in a week to see if anyone can post a better answer.

The problem lies in the code page. I set my default display language for Windows 10 to be Simplified Chinese, with GBK code page (936). So, in cmd windows, the system intends to show all the information in Chinese. Actually, we see that in the first images I posted in the question, the beginning lines of help information are shown in Chinese.

To show something in Chinese, you have to find a proper font to provide the hinting information for Chinese characters. Apparently, Windows checks all fonts beforehand to see its support to current code page characters. When it sees that the set font has no Chinese support, it will abandon this font and falls back to the default font. Also, it will get rid of this font from the font setting list in the Default panel. Yahei Consolas Hybrid supports both English and Chinese, so it can be shown in the list in Default and Properties settings. Monaco and Dejavu, however, disappeared from the Default panel, but remain in the Properties panel.

Why does it not clear the Properties font list, too? Because as the comments say, "Properties" applies to the current cmd windows/session, while "Default" settings controls all the subsequent cmd sessions, e.g., more global. It ensures that if the user changes the code page in the run-time, it has not to do the font list checking again for Properties, and the user can change font directly. That's exactly what happens in my case. I must say that Windows has done much background work here.

You can see in the following screenshot that I changed the code page with chcp 1252 and the font change takes effect immediately. It's Monaco now.

enter image description here

So, the question turns to: "How to change the code page upon starting a cmd window?" And I found a very useful question:

Change default code page of Windows console to UTF-8

And I simplify the change to:

  1. Create a .reg file, name it as you wish.
  2. Copy these lines into the file and save.

Just type:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Command Processor]
"Autorun"="chcp 1252>>nul"

1252 can be other values. >>nul is to avoid printing

Active code page: 1252

every time you launch cmd.

  1. Run the file to import the settings.
  2. Run cmd. Now you can set your font easily in Properties. (I note that if you run from a link in desktop, the font is Simsun, but if you run from anchor in the task bar, it's Yahei Consolas Hybrid. I don't know why. But you can just change the font.

Set the default font in Default doesn't work for subsequent sessions of cmd, though. It still falls to Simsun, so I cannot achieve "Open cmd and with Monaco font". I think it is because Windows checks current language code page with fonts, not the "autorun" code page with fonts., so changing the default language can be working but that's not what I want. I am still with this topic.

0

Now in Region Setting (Region/Administrative[tab name] and then Change system locale...), there is a check box which says "Beta: Use Unicode UTF-8 for worldwide language support". Check it and it'll probably work. I'm currently on Windows 10 build 17134.165.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.