18

The problem: Lord of the Rings Online required .NET framework 1.1 to be installed. It will not recongize other higher versions. Downloading the standalone installer yields exceptions at the end of the installation process.

The error message is

"Application has generated an exception that could not be handled"

What could I do about this?

18
  1. Create a new folder named DotNet in C:\ drive. (The path I used was C:\DotNet )
  2. Make sure the setup file is saved as dotnetfx.exe.
  3. Download Microsoft .NET Framework 1.1 Service Pack 1 from the link below: http://www.microsoft.com/downloads/details.aspx?FamilyID=a8f5654f-088e-40b2-bbdb-a83353618b38&displaylang=en Rename the file to dotnetfxsp1.exe.
  4. Copy both installation files into the same directory (i.e. C:\DotNet),.
  5. Open Command Prompt as Administrator.
  6. Change to the directory where the two installation files are stored, ie C:\DotNet.
  7. Run the following commands one by one.

    dotnetfx.exe /c:"msiexec.exe /a netfx.msi TARGETDIR=C:\DotNet"

    Picture of Confirmation dialog

    Click Yes and wait for this dialog which says installation complete.

    Picture of Completion acknowledgement

    dotnetfxsp1.exe /Xp:C:\DotNet\netfxsp.msp

    msiexec.exe /a c:\DotNet\netfx.msi /p c:\DotNet\netfxsp.msp

    Picture of Progress bar

    Wait for the installer to disappear automatically.

  8. Install Microsoft .Net Framework 1.1 with slipstreamed Service Pack 1 by running netfx.msi from the working folder.

Source: http://social.answers.microsoft.com/Forums/en/w7programs/thread/18093af8-54af-457c-bfdc-184c63cf4941

  • Works flawlessly for me :) – o.k.w Jan 31 '11 at 9:33
2

Extrakun,

I have used this to install it on one of my client Windows 7 machines. One (to which i couldn't actually view because i'm at work, however the URL seems about right) describes how to install the .NET FW 1.1 on Windows 7: http://saranspot.blogspot.com/2009/02/installing-dotnet-framework-11-on.html

2

I had the same error. Solution is, when search for the command prompt, right click to the command prompt and choose run as administrator. The problem solved!

Not the answer you're looking for? Browse other questions tagged or ask your own question.