2

1. The issue

Apologies but this is going to be a bit lengthy: my current laptop (Dell XPS 9550) has a 4k screen and is currently being run at 4k, its default state. This did take a bit of playing around for certain applications that weren't behaving very well but eventually I managed to get everything scaled nicely to fit my 4k laptop screen.

I have recently purchased a monitor (ASUS VC239H 1080p) that I use with an external keyboard and mouse to serve as my primary monitor at home (laptop closed). When I initially plugged it in, windows was driving the 1080p screen at 4k (I'm guessing the screen automatically downscaled this) and everything looked perfect: an exact replica of how things look on my 4k laptop screen with a drop in resolution.

However, as soon as it was connected I got a compatibility issue notification from Windows saying that the screen only supports up to 1080p and I should change the driving resolution. I initially ignored this since everything was behaving exactly as desired but out of curiosity I eventually clicked that notification. This brought me into the following hellhole:

Immediately after clicking the notification, the driving resolution for the 1080p monitor was automatically changed to 1080p (instead of the previous 4k) and all the applications I had tweaked to look good in 4k automatically became huge and no longer fit on the screen. When I tried to reverse what I had just done I found that I couldn't. Windows has greyed out the option to drive my 1080p monitor at 4k because it has detected the monitor can only display up to 1080p (it remembers this setting every time I connect my laptop into the display). I am therefore stuck with a horrendous scaling of many applications that are scaled for 4k and I do not want to endlessly rescale applications when I take my laptop away from home and use my laptop display instead of my home monitor. Note that when I plug and unplug the monitor (even with a restart) windows 'remembers' that I selected 1080p for this monitor and refuses to give me the option to drive it at 4k.

So my question is: how can I get windows to drive my 1080p monitor at 4k instead of 1080p?

Fun fact: I can get my 1080p monitor to behave as it should if open my laptop lid and set the display to duplicate. This will drive both displays at 4k but requires my laptop to be open which is a major issue. (note: this has nothing to do with close lid action in power settings since it is set to do nothing, this is about windows detecting that two displays are available and giving me the option to set the screen resolution to 4k)

2. The solutions attempted

Here is what I have tried thus far to fix my issue:

  1. Uninstalled and reinstalled driver.

  2. I tried to get Windows to somehow 'forget' the display to replicate the behaviour I got when the display was connected the first time. I uninstalled the display driver and even tweaked the registry but it still 'remembers' to run the display at 1080p without giving me the opportunity to let it run at 4k. I can't find a way of getting windows to fully forget this monitor and get it to behave as it did before I clicked on the notification.

  3. I tried to get my NVidia Graphics card (GTX960M) to force 4k driving but this option is not available for my graphics card.

  4. I tried to get the laptop screen to stay on when the laptop is shut (thus pretending the laptop is open and driving both displays at 4k) but this is a hardware switch triggered by the hinge and cannot be altered.

Edit: using Sysinternal's Process Monitor, I have managed to isolate a few critical Registry keys that are being affected. If anyone could explain what these keys do, that may resolve my issue: Concerned Registry Keys As you can see it does indicate a resolution of 1080p instead of 4k...

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.