0

-Windows 7 Home Premium, 64-bit, Administrator account

Previously, my password stopped being a valid entry to login to my Windows 7 user account. I didn't change it. Possibly a memory error, but I really don't know. To band-aid the issue, I used Konboot to remove the password and I now have access to this account by just hitting the Enter key instead of entering a password. But, this is of course no good as I would prefer to have a password.

When I attempt to create a password for this account, Control Panel tells me that, "The password you typed is incorrect. Please retype your current password." There is no option to enter the old password before I enter a new one in this menu, as the menu is "Create a password for your account," not "Change your password."

Why/how could this have happened?

5
  • The solution, use the built-in Administrator account, and reset the password for the user. There isn't enough information to determine the reason what you describe happened
    – Ramhound
    Apr 22, 2017 at 16:00
  • It's very odd, but it worked. I used built-in Administrator to create a password for the other user account, but Administrator couldn't create a password for itself, exactly how the other user account couldn't create a password for itself. Creating another account and allowing it to be an administrator gave me the ability to add a password to Administrator. This is extremely weird. My question wasn't answered, but my issue IS fixed. :D Apr 22, 2017 at 23:36
  • 1
  • 1
    I don't believe so. I've always had more than one account with administrator privileges loaded onto this system. My issue wasn't that an account couldn't be accessed. The issue is that accounts can't create their own passwords, not even administrators. What's strange is that it says that correctly-entered passwords are incorrect. What's even more strange is that an account with a null password is given the same error when adding a password where there isn't one. Apr 23, 2017 at 0:09
  • Even after you reset the password for the account, you still can't change the password, what about creating a new user account and confirming the behavior with that?
    – Ramhound
    Apr 23, 2017 at 0:13

2 Answers 2

0

Solution

This solution applies strictly to the poster of the question.

  1. Create a new administrator account
  2. Log in using the new account
  3. Open the Computer Management console. You can right-click on Computer and select Manage.
  4. Open Users and Groups node, and then Users sub-node.
  5. Right-click on your old administrator account and select Set Password...
  6. Read the warning, acknowledge it and click the Proceed button.
  7. Set a new password.

You are done. Log out, log in with the old account and its new password, delete the temporary user account and its profile and restore your EFS encryption certificate.

Warning for other readers

The original poster of the question is using Windows 7 Home Premium. You, on the other hand, might be running another edition of Windows 7, 8, 8.1 or 10 that has Encrypted File System feature and you may have used it to encrypt files.

If this is the case, before following the instructions, please make sure you have backed up your EFS encryption certificates. (Windows might have already prompted you to do this.)

3
  • After I create a new administrator account, with it I can add passwords to other accounts and add a password to itself once. Managing other accounts with the new administrator is restricted to "create password" not "change password." However, after creating a password while working in the same login session, the "change password" option becomes available in the User Accounts menu. Upon selecting the "change password" option, it gives me the header of the "change password" menu, but only the text fields of the "create password" menu. Apr 23, 2017 at 12:33
  • Upon logging off and logging onto any account, including the same one, my User Accounts menu is back to displaying the "create password" option. While the new account was able to create a new password for itself for the first time, changing the password or select "create password" any time after that yielded the same results as the previous. Apr 23, 2017 at 12:39
  • And after all of that, an account creating a password for itself, even though it may already have one, yields an "incorrect password" message and a failed attempt to create/change the password for itself. Apr 23, 2017 at 12:49
0

Coming back after some time:

The only functional way I was able to change my password was Ctrl + Alt + Del -> New Password, so it's a bit embarrassing that I didn't think of that before. It certainly did not work from the Manage Users.

Re-installing Windows 7 removed this memory error.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .